Forum Discussion

slecault's avatar
4 years ago

Android app not responsive to mouse click


Our mobile app is developped using Xamarin (not Form).

Both iOS and Android have the same global look and same functionnalities. 

I have scripts that ran fine on both OS until a merge/integration for Android API level 29 (Android 10). 

I tried with latest version of TC 14.80 (no change)

I have updated Android SDK up to version of Android 11

I have a Samsung Tab S2 physically connected to usb port Running Android 7.0

I am able to interact with Android device, (mouse click reacts like if I was touching the device (outside my tested app)


Since this integration (API target for Google Play), our tests won't run on the Android app, iOS are ok.


I can spy the app and see detailed structure of it in the "Object Browser". I can swipe/scroll with the mouse.  I can use the arrows on the desktop keyboard to navigate and press "Enter" to kind of "touch" a control.  But mouse clicks have no effect on the app (tried left, right, center, left-right, long left) .


Any ideas are welcome.


10 Replies

    • slecault's avatar

      Hi Alex,

      I did open a case in late december. In order to investigate, support wants to get the app which won't work outside our building because it needs to interact with our server.  

      I was hoping someone else had seen this behavior and might share what they did to resolve the situation.



      • AlexKaras's avatar
        Champion Level 3



        I see...

        I do not remember that someone mentioned such problem here thus suggested to contact Support directly...


        P.S. I am sure that you tried .Touch() and .Keys('[Enter]') as possible workarounds for the problem, didn't you?


  • Hi Sonya,


    The problematic app described in this topic is no longer being tested by my team (nor other team!). It is being replaced.


    Thanks (now moving into our new app and starting from scratch with Appium)