Ask a Question

TestComplete issues with Chrome 113


TestComplete issues with Chrome 113



this is a general message about TestComplete issues with Chrome 113

Please note that the current version of our product may experience issues when used with Google Chrome 113. We apologize for any inconvenience this may cause. Our team identified this is Chrome issue and we are working on a permanent fix. We appreciate your patience as we work through this issue.

The dev team on our side is already working to solve the problem. We expect the problem to be solved by the middle of next week. 

More updates will be provided here in this thread.
Really appreciate your patience and sorry for inconveniences.


Best regards,

Pawel Mularczyk

Product Manager for TestComplete


139 REPLIES 139
Occasional Contributor

On top of these issues, I think since the new Chrome versions, page waits are acting up as well for me.
Some pages that I know usually take a few seconds to load are now failing and looking at the test and results, TC tries to find the object immediately even when specifying a wait time.


Hmmmm, support asked that I run repair on my version of TC... and if that does not work, perhaps try to downgrade.... 


I am holding off on running repair. as when I refer to that link that explains how to do that, it mentions I should probably export my settings and the such...


I am holding off on trying that, until I know some folks are having luck with latest Chrome and latest TC?


Is anyone running latest TC and latest Chrome successfully yet?


 Thanks folks.  I apologize if I missed that somewhere.

@rpfaucher1 It looks like several users seem to be working fine with the latest browser versions of Chrome and Edge using the latest version of TestComplete, and several users, like me, are still experiencing issues using the latest version of TestComplete. So TestComplete 15.51 is working, but not for everyone. The only way you'll know whether it works or not is to upgrade it yourself and try it. Exporting your settings is easy, as is importing them. Running the repair is also easy - essentially the same as installing it again.

Thank You.... So, I am indeed running the latest TestComplete and the Chrome 113....93 and does not work.  


I may try the repair and see if that makes any difference at all... I had thought no one else running these two versions was having any luck, but sounds like some are ok  Just weird, Lol.


Thanks again for the reply - and just to be clear, the older version of TestComplete (for me anyways)

is working.  


Chrome: V 113....93
With TestComplete V
DOES work
That same Chrome Version with latest TC.... does NOT work.  Sorry for any confusion.
Regular Contributor

on my workstation

I have this version of Chrome installed: 113.0.5672.127 (Official Build) (64-bit)

I have this version of TestComplete installed: 15.51.187 x64


are these the latest/greatest? are they the ones that should be fixed/working together?


i have three browser based apps that all require login credentials in order to get started and, since all this stuff about TestComplete and Chrome started over a week ago, TestComplete does not recognize a single one of the elements (username, password textboxes, buttons) on any of the credentials forms when I run any of these apps on my workstation. i have opened a support case with smartbear but i'm not getting any response or help from them. does anyone here have any idea what might be wrong or a suggestion of what i might try?



Regular Contributor

Excuse me, that should have read x64 (i had omitted the dot between the 18 and the 7). normally i got the impression that the releases/versions/builds between testcomplete and testexecute were supposed to match up node for node but I just noticed that while the last node of my testcomplete version is 7, the last node of my testexecute that is installed is 11. 



just curious, is there not an 11 build for testcomplete?

Regular Contributor

Below I am pasting in the text and images that I just sent to the smartbear support case that I have opened about this issue. Again, this all seemed to start when all this other stuff started happening with testcomplete/chrome so I'm keeping it in this thread. If this is not the proper place for it, please let me know. 


Here is an interesting development. Not sure if it will help you in your research/investigation but hopefully it will.


I just tried running a test case for another one of my browser based applications that requires login credentials at the start. The first image shows the keyword recording where the username and password are entered with a SetText statement and then followed by the clickbutton event on the signin button.





For a brief moment it appeared as though it was going to be successful. The username was entered. The password was entered. But when it came time to click the submit button it couldn’t find that object.





Here is how the screen looked. As you can see the username and password textboxes are filled in. however, after the test failed I right clicked on the username line in the keyword recording (first image above) and selected the Hightlight on Screen and now it cannot find it (even though it did find it just a few seconds before).






Here is the namemapping for all three of these objects with the one for the username selected.






Can you tell me why my testcomplete is behaving this way?

Occasional Contributor

I am experiencing this same issue.  Single elements are not being recognized.  It was working for awhile last week, but it looks like Chrome had another update. I'm not sure what to do either. Getting very frustrated.


Just checking to see if anyone else has any updates?  Our Chrome has updated and now here is my status of what works and what doe not... appears latest Chrome with latest TC still not working for me...

older TestComplete and latest Chrome is working... so far.  


This works:
TestComplete Version: x64
Chrome Version: 113.0.5672.127
This does NOT work:
TestComplete Version: x64
Chrome Version: 113.0.5672.127

@dhundley :


just curious, is there not an 11 build for testcomplete?

No, there is no .11 build for TestComplete.

This numbering system has, probably, historical roots, but it exists for more than decade already.

Initially, TestComplete and TestExecute had Standard and Enterprise flavors.

Standard flavor for TestComplete ended with .5 (if I remember it correctly).

Enterprise flavor of TestComplete ended with .7.

For TestExecute Standard flavor ended with .9 (IIRC) while Enterprise flavor ended with .11.

Build number was in third set of figures. Prior to version 14 (IIRC) build numbering was continuous through all major version of the product (i.e. starting from, say, 12.0 and until final 12.x is released). Now build number seems to be reset for every minor version.


  /Alex [Community Champion]
[Community Champions] are not employed by SmartBear Software but
are just volunteers who have some experience with the tools by SmartBear Software
and a desire to help others. Posts made by [Community Champions]
may differ from the official policies of SmartBear Software and should be treated
as the own private opinion of their authors and under no circumstances as an
official answer from SmartBear Software.
The [Community Champion] signature is assigned on quarterly basis and is used with permission by SmartBear Software.
Showing results for 
Search instead for 
Did you mean: