Forum Discussion

tristaanogre's avatar
tristaanogre
Esteemed Contributor
2 years ago

Chrome Extension for Chrome version 111, TestComplete version 15.49

Hello, everyone... I'm back.  Been a hot minute I know.

Anyways, so, I know this may seem like a bit of a newbie question for someone with as much experience as I have but here's the situation.

We recently upgraded our machines to use TestComplete version 15.49.  However, the version of Google Chrome on the machines is version 111.  When I launch TestComplete and try to examine web applicatioin in Google Chrome, I'm unable to see the applications as "open".  It seems that the version of the Chrome Extension that is installed with TC 15.49 is not compatible with Chrome 111 (although, I could be wrong).

Is there a patch or is there some configuration that I'm missing here to get Google Chrome applications to show as "open" in TC 15.49.

 

UPDATE: Actually, it's a little odder than that.  I have two different machines with the same version of Chrome, Windows, and TC.  One machine has the problem described above...the other machine doesn't.  So... it's not a matter of a Chrome patch, but something else. 

Any thoughts from anyone?

 

Thanks in advance

  • Is TC not able to identify any of the UI controls? Is that what you mean by "open"?

     

    You might need to reinstall About SmartBear Test Extension. Even though v111 is not supported, TC does sometimes fails to identify objects, but works after restarting Chrome

8 Replies

  • rraghvani's avatar
    rraghvani
    Champion Level 3

    Is TC not able to identify any of the UI controls? Is that what you mean by "open"?

     

    You might need to reinstall About SmartBear Test Extension. Even though v111 is not supported, TC does sometimes fails to identify objects, but works after restarting Chrome

    • tristaanogre's avatar
      tristaanogre
      Esteemed Contributor

      Yeah, I'm trying the reinstall right now. 

      Sorry about the "open" language... I started with AQ Test version 1.5 back in the day and that's what we called applications that we were able to "see" components and controls on. 🙂

       

      Let me try the reinstall and I'll get back to yo.

    • tristaanogre's avatar
      tristaanogre
      Esteemed Contributor

      Yup, that did it.  For whatever reason, the install was corrupted on that machine.  As I said, rather newbie question.  Thanks for the assist, rraghvani 

  • tvklovesu's avatar
    tvklovesu
    Frequent Contributor

    Hi,

    Sorry to hijack your question. I am recently seeing this issue and this extension is not enabled in chrome. I have this extension on both Chrome and Edge, but for Chrome it is not working. As the machine is managed by my IT, I cannot reenable this extension. I got on call with my IT and made them login to my system as Administrator and tried to install the extension. But everything gone in vain. Even with admin rights I am seeing this same error as posted in the image. 

    I even tried to reinstall by using Update to latest version. I did not uninstall and reinstall, but just upgraded to.

    Any thoughts that I am missing here.

     

    TIA

    • tristaanogre's avatar
      tristaanogre
      Esteemed Contributor

      This looks to be a policy issue within your company that there's a GPO of some sort that is preventing extensions from being installed or enabled.

    • tvklovesu's avatar
      tvklovesu
      Frequent Contributor

      rraghvani, I tried this with help of my IT admin and still its not working. Also uninstalled the app and reinstalled completely with latest version. No luck. Any other suggestions.

      Thanks

  • rraghvani's avatar
    rraghvani
    Champion Level 3

    If you have admin rights on your computer and nothing else is working, the only last resort is to either reset Chrome to its original settings, or reinstall Chrome. 

     

    Just make a back up of your bookmarks etc.