Ask a Question

Object spy issue for a desktop application

Champion Level 0

Object spy issue for a desktop application

There is an issue in object spy, The object which I want to find is in the bottom end of the application, But TestComplete is identifying somewhere else when using object spy, Attached screenshot for reference, Marked in green for the required object, and Red box is the TestComplete highlighted object.

Please suggest me what to do?
@rraghvani @AlexKaras @mikef @Marsha_R @Egg 

Frequent Contributor

Hello Sir, Nice to meet you. 

When I confront like that situation.

First, I Check the Testcomplete's Version. 

and I update up-to-date. 

or Reinstall. 


and Second, Is that Desktop App? 

also update that to up-to-date. 


Please do up two things. 

and the problem isn't solve at one time. 

Please contact cotinuously in this Question page. 



Hi Egg, Thanks for responding.

But I have tried every possible way to resolve this issue,

1. As soon as I faced this issue, I update the TestComplete to its latest version.

2. Reinstalled the AUT.

3. Tried adding its "WndClass" object to project settings.

4. Checked JRE versions.

5. Check for other applications.


The object spy works good with other application, but when it comes to my AUT it doesn't recognize it correctly.

Can you suggest any other alternate?

Frequent Contributor

I'm sorry to hear that.. 

then.. maybe I Think Testcomplete couldn't support your desktop app... 

Can I test your app? what's that? what's the main fucntion?


Hi @abishekhari007 


I would check the scaling settings for the application under test and TestComplete are set to "Application". You can find this by right-clicking on each app launcher icon, click on Compatibility tab then "High DPI Settings". Make sure the High DPI scaling is set to Application.


If this still does not work, I suggest sending a support ticket which, if an issue is found, can be escalated to the dev team to investigate.



No Egg, TestComplete supports this application for automation, I have tried automating this application in my personal laptop which works on Windows Pro and there its working fine, But I have to automate this inside my client provided VDI where its causing this issue, Do you suspect if it might be because of OS change?

Champion Level 3

Agree with @mikef . Also check your Windows Scale and layout is set to 100%

Hi Mike, Thanks for the response,

This was the first thing I checked when I encountered the issue, and all the DPI settings seems to be as expected "Application".

All the settings are correct, Cross checked before and even now, custom scaling is set to 100 and DPI is set to applications. I have also raised a support case for the same issue.

Not sure If I am missing something?

Regular Contributor

Is this only an Object spy issue, or does TC also fail when clicking/using the object from within a test?

Showing results for 
Search instead for 
Did you mean: