cancel
Showing results for 
Search instead for 
Did you mean: 

getting Runtime error '398' client site not available

SOLVED
Occasional Contributor

getting Runtime error '398' client site not available

Hi Community,

 

I am working on desktop VB application. Initially I've built scripts on testcomplete 12.60 using Javascript. Now, client asked us to migrate the scripts to testcomplete 14. So, when I import the scripts to testcomplete 14 and execute them, I see some properties got missing/changed. And also I can see a runtime error '398' Client Site Not Available. And again when I run in TC 12.60, it works fine. Can anyone tell what is the resolution for these?

 

Regards,

Nandini.

1 ACCEPTED SOLUTION

Accepted Solutions
Community Hero

Re: getting Runtime error '398' client site not available

Name has always been a separate property.  NativeVBObject is an object itself which probably has it's own "Name" property.  So, this shouldn't be a problem.  Are you getting errors in identifying the objects or is that still working?  you can still map the object using NativeVBObject... it's still there on the screen, you just need to select it and select the NAme property of that object.

 

As for the error... that's not a TestComplete error, that's an error coming from your application under test.  You need to investigate that with your team.

 

As as ide note, the regular "Name" property should not be used as an identifying propery... it bypasses NameMapping entirely.  

 

 


Robert Martin
[Community Expert Group]
Please consider giving a Kudo if I write good stuff
----

Why automate?  I do automated testing because there's only so much a human being can do and remain healthy.  Sleep is a requirement.  So, while people sleep, automation that I create does what I've described above in order to make sure that nothing gets past the final defense of the testing group.
I love good food, good books, good friends, and good fun.

Mysterious Gremlin Master
Vegas Thrill Rider
Extensions available

View solution in original post

6 REPLIES 6
Community Hero

Re: getting Runtime error '398' client site not available

What properties are missing/changed?  Are you talking about configuration options under Tools | Options?  Or are they items within the test cases?  At what point in your code/test do you get the error?


Robert Martin
[Community Expert Group]
Please consider giving a Kudo if I write good stuff
----

Why automate?  I do automated testing because there's only so much a human being can do and remain healthy.  Sleep is a requirement.  So, while people sleep, automation that I create does what I've described above in order to make sure that nothing gets past the final defense of the testing group.
I love good food, good books, good friends, and good fun.

Mysterious Gremlin Master
Vegas Thrill Rider
Extensions available
Occasional Contributor

Re: getting Runtime error '398' client site not available

Hi tristaanogre,

1. I am talking about object properties while doing NameMapping.

I used a property name:NativeVBObject.Name in Testcomplete 12.60 version as its a unique property for my object. When I upgraded to TC14, I see NativeVBObject and Name as two seperate properties.

 

2.Regarding the error 398, when I execute the script, the application is launched and able to login and after that I am getting the runtime error immediately and not able to proceed further.

Please refer the screenshots attached.

 

Community Hero

Re: getting Runtime error '398' client site not available

Name has always been a separate property.  NativeVBObject is an object itself which probably has it's own "Name" property.  So, this shouldn't be a problem.  Are you getting errors in identifying the objects or is that still working?  you can still map the object using NativeVBObject... it's still there on the screen, you just need to select it and select the NAme property of that object.

 

As for the error... that's not a TestComplete error, that's an error coming from your application under test.  You need to investigate that with your team.

 

As as ide note, the regular "Name" property should not be used as an identifying propery... it bypasses NameMapping entirely.  

 

 


Robert Martin
[Community Expert Group]
Please consider giving a Kudo if I write good stuff
----

Why automate?  I do automated testing because there's only so much a human being can do and remain healthy.  Sleep is a requirement.  So, while people sleep, automation that I create does what I've described above in order to make sure that nothing gets past the final defense of the testing group.
I love good food, good books, good friends, and good fun.

Mysterious Gremlin Master
Vegas Thrill Rider
Extensions available

View solution in original post

Occasional Contributor

Re: getting Runtime error '398' client site not available

Hi Tristaanogre,

 

Thanks for your response. I understand the object property issue.

Related to error 398, if that's an error coming from the application under test, I see its running successfully through testcomplete 12.60. Is it due to any migration issue?If so, what would be the solution?

 

Regards,

Nandini

Community Hero

Re: getting Runtime error '398' client site not available

I don't know.  This would probably be something best answered with the official SmartBear support.

 

https://support.smartbear.com/message/?prod=TestComplete


Robert Martin
[Community Expert Group]
Please consider giving a Kudo if I write good stuff
----

Why automate?  I do automated testing because there's only so much a human being can do and remain healthy.  Sleep is a requirement.  So, while people sleep, automation that I create does what I've described above in order to make sure that nothing gets past the final defense of the testing group.
I love good food, good books, good friends, and good fun.

Mysterious Gremlin Master
Vegas Thrill Rider
Extensions available
Community Manager

Re: getting Runtime error '398' client site not available

Hi @nandini9,

 

I'm glad to hear that the object identification question is answered.

 

Regarding the error inside the application, I suggest that you debug this part with TestComplete. Perhaps, TestComplete 14 transfers some data that your app doesn't accept. There are may be many reasons. Debugging this test will help you understand what is going wrong.

---------
Tanya Gorbunova
SmartBear Community Manager

Did my reply answer your question? Give Kudos or Accept it as a Solution to help others.↓↓↓↓↓