Forum Discussion

wmtan01's avatar
4 years ago

Running in RDP - Chrome/Edge Chromium not performing actions



I've noticed that the UI does not update on some of our test cases even though the test script says that it should do something. For example the following KWT should type in a message and hit send:

This KWT is called multiple times in testing of our chat application. When I was watching the execution I noticed that the Chrome/Edge window (in the video I will attach it is Edge) seem to be frozen, like the actions were not being done but for some weird reason the results of those actions are still being seen by the 2nd participant in the chat (opened in Firefox). See attached video for clarity. Notice that in the middle part of the video, the application actually updated I think it was when the click to the Vehicle Info tab was done.


I've seen this happen multiple times in various machines and I let it be because it did not seem like it was breaking things. But then one of our machines started this behavior:

 So the test logs were saying that "Send" button was clicked but it was not as indicated by the compounded messages. Expected would be similar to what was in the video. And now this actually causes the test cases to fail because our application only enables certain controls once a message is sent. And in this case those messages that were supposed to get sent did not get in.


I only see this happening on Chrome/Edge Chromium. I'm wondering if the Smartbear Extension could be broken for when executing test cases with multiple browsers open. It is working correctly on my local and on some of our other Run Agents as well. I've tried it both for the latest TestComplete version and the one before that 14.6X.


I hope someone can shine a light on what's happening and how I can fix/do a workaround.

  • As far as understand from support ticket 00468274, restarted environments helped get rid of this issue. Feel free to update this thread if you encounter the issue again wmtan01 

3 Replies

  • Marsha_R's avatar
    Champion Level 3

    When the log says a button is clicked but your test is not behaving as you expect after that, it's frequently the case that the click is happening, just not in the location you expect.  You can check this a couple of different ways. 


    One, you can use Debug mode to step through the test and watch where the click is actually occurring on the screen.  If this is the problem, then make sure you are using object properties to click on the button rather than coordinates (which can be different on different machines).   


    Another way is to turn on Visualizer and look at the images there to see where the click is happening.  The fix is the same as before, using objects instead of coordinates.



    • wmtan01's avatar

      I actually had some time this morning to debug this further. It seem TestComplete thinks the controls are a little bit higher in the page. When I added some click actions, I could see the cursor moving and I guess clicking things though that is not where the controls actually are.


      I opened a ticket with SmartBear and it seems the issue might be because of the machine resources preventing Chrome/Edge from performing the Front End stuff basically the browser is in a frozen state. I did try reducing the open applications on the running machine and it seems to have solved it. I'm just worried now that the resource requirement for our tests to work seem to be higher than before, or possibly TestComplete might be consuming more.

      • sonya_m's avatar
        SmartBear Alumni (Retired)

        As far as understand from support ticket 00468274, restarted environments helped get rid of this issue. Feel free to update this thread if you encounter the issue again wmtan01