Ask a Question

TestComplete, Auto-wait timeout sets to 50ms by itself

SOLVED
Kraku
Occasional Contributor

TestComplete, Auto-wait timeout sets to 50ms by itself

I have a problem with auto timeout setting in Project/properties/playback/Runtime. My default is 20 seconds, but it can change itself spontaneously to 50ms. I have identified two moments when this happens. But I'm sure there is more, because even without that actions this timeout is changing to 50ms.
What I'm doing wrong? What I have missed? Where I should look?

Look at video I made with this issue:
https://www.youtube.com/watch?v=poWAMmENGps

1 ACCEPTED SOLUTION

Accepted Solutions

Re: TestComplete, Auto-wait timeout sets to 50ms by itself

Hi Kraku,

 

This is a known problem in TestComplete 12.30 indeed. We have a patch for the problem and you can get it if you submit a request via the Contact Support form.

 

Thank you!

--
Dmitry Nikolaev

Did my reply answer your question? Give Kudos or Accept it as a Solution to help others. ⬇️⬇️⬇️

View solution in original post

7 REPLIES 7
Bobik
Frequent Contributor

Re: TestComplete, Auto-wait timeout sets to 50ms by itself

It's definitely a bug in TestComplete. Contact support and report this issue. 

shankar_r
Community Hero

Re: TestComplete, Auto-wait timeout sets to 50ms by itself

Hi,

 

The Auto-wait timeout you seeing in the Project > Playback options is for execution not in the idle time.

 

After changing the time out having tried to run the project and see whether TC waits for that mentioned time.

 

From Smartbear doc

 

------------------------------------------------------------------

Auto-wait timeout, ms - Default: 10000. When a test acquires a reference to a process or window object, or when it activates an object (for example, opening a minimized window), the object may not be available immediately. Likewise, when a test commands a change in the onscreen state of a window (e.g. minimizing an open window), or when TestComplete attempts to close an unexpected window, the change may not occur instantaneously. Auto-wait timeout is the number of milliseconds allowed for the object to become available, or for the desired change to occur, before a timeout error message is posted to the test log. If the object becomes available or the desired change occurs within the delay allowed, the test proceeds immediately. If the timeout elapses, what happens after the error is posted is determined by the Stop on Error option.

Auto-wait timeout affects the following test methods that return references to new objects:

To change this option from your tests, use the Options.Run.Timeout property.

---------------------------------------------------------


Thanks
Shankar R

LinkedIn | CG-VAK Software | Bitbucket | shankarr.75@gmail.com

“You must expect great things from you, before you can do them”

Extension Available

Re: TestComplete, Auto-wait timeout sets to 50ms by itself

Hi Kraku,

 

This is a known problem in TestComplete 12.30 indeed. We have a patch for the problem and you can get it if you submit a request via the Contact Support form.

 

Thank you!

--
Dmitry Nikolaev

Did my reply answer your question? Give Kudos or Accept it as a Solution to help others. ⬇️⬇️⬇️

View solution in original post

Kraku
Occasional Contributor

Re: TestComplete, Auto-wait timeout sets to 50ms by itself

If I set tmeout to 20000 and then execute test, it waits 20 sec. If I do actions like presented in video and then I execute test, TC uses the 50ms timeout.

TanyaYatskovska
Community Manager

Re: TestComplete, Auto-wait timeout sets to 50ms by itself

Hi Kraku,

 

Please let us know how the things go after installing the patch.

---------
Tanya Yatskovskaya
SmartBear Community and Education Manager

Did my reply answer your question? Give Kudos or Accept it as a Solution to help others. ⬇️⬇️⬇️
Kraku
Occasional Contributor

Re: TestComplete, Auto-wait timeout sets to 50ms by itself

After applying the patch, issue is solveed.
Thank you !

TanyaYatskovska
Community Manager

Re: TestComplete, Auto-wait timeout sets to 50ms by itself

Awesome!

---------
Tanya Yatskovskaya
SmartBear Community and Education Manager

Did my reply answer your question? Give Kudos or Accept it as a Solution to help others. ⬇️⬇️⬇️
cancel
Showing results for 
Search instead for 
Did you mean: