SmartBear Connect 2018
Join us at SmartBear Connect 2018 on October 29th & 30th in Boston, MA.
Apply to speak and share your experience with the greater SmartBear Community
Reply
Occasional Contributor

Chrome v64 Alerts Not detected

I am testing a web application that has an Alert pop-ups to tell the user of missing information when they try to save the form. The Alert is still detected and closed within IE, and it previously worked with Chrome v63; however, it no longer is working with Chrome Version 64.0.3282.167 in conjunction with TestComplete Version: 12.42.3048.7 x64.

 

Any help would be greatly appreciated!

 

 

Highlighted
Posts: 5,426
Topics: 42
Kudos: 2,367
Solutions: 478
Registered: ‎11-30-2009

Re: Chrome v64 Alerts Not detected

According to https://support.smartbear.com/downloads/testcomplete/chrome-patches/, Chrome v 64 shouldn't have any problems with that version of TC.

 

The question is, though... what do you mean by "no longer working"? What error messages are you getting?  What's happening when it tries? It's entirely possible that Chrome changes some of the way that the Alert's are identified in memory which would mean that Aliasing/NameMapping would need to be updated or some other code changes would need to be made to support the latest Chrome version.


Robert Martin
[Community Expert Group]
Please consider giving a Kudo if I write good stuff
----

Why automate?  I do automated testing because there's only so much a human being can do and remain healthy.  Sleep is a requirement.  So, while people sleep, automation that I create does what I've described above in order to make sure that nothing gets past the final defense of the testing group.
I love good food, good books, good friends, and good fun.

Extensions available
Community Leaders Program
Frequent Contributor

Re: Chrome v64 Alerts Not detected

First check your chrome version according to Test Complete patches on below:
https://support.smartbear.com/downloads/testcomplete/chrome-patches/

 

Now change your browser settings according to
https://support.smartbear.com/testcomplete/docs/app-testing/web/general/preparing-browsers/chrome.ht...


Frequent Contributor

Re: Chrome v64 Alerts Not detected

First check your chrome version according to Test Complete patches on below:
https://support.smartbear.com/downloads/testcomplete/chrome-patches/

 

Now change your browser settings according to
https://support.smartbear.com/testcomplete/docs/app-testing/web/general/preparing-browsers/chrome.ht...

Occasional Contributor

Re: Chrome v64 Alerts Not detected

@tristaanogre  I have included a couple screenshots of the Alert box in Chrome and IE when trying to recognize the okay button during recording. Also, when using F12 within the browser for the Dev Tools operation, it does not allow me to view the box as it's own feature in Chrome.

 

Does this information help?