Forum Discussion

sothqamb's avatar
sothqamb
Occasional Contributor
2 years ago
Solved

Screen elements in Chrome mobile view not detecting properly

TestComplete is having issues with both my Chrome and Edge (chromium based) in detecting objects properly while in the mobile view, and i'm not sure how to fix it. I am not having this issue with Firefox.

In the attached image my cursor was over the sign in box, and the object it is selecting is what would be the username textbox

 

 

if you have any suggestions on how to get the chromium based browsers to work in the mobile view it would be greatly appreciated

  • Hi sothqamb - 

     

    Even with a remote machine you can check the display settings. By default they are not always set to 100% so I would still suggest this as your first approach. It also could have to do with how you are using the browser in the smaller size. For this i would suggest running the TestComplete "Run Virtual Browser" operation to re-size the browser - to make sure TestComplete can properly identify elements within the re-sized window (https://support.smartbear.com/testcomplete/docs/keyword-testing/reference/web/run-virtual-browser.html)

     

    Let me know if you have additional questions. 

     

    Emma

4 Replies

  • Hi sothqamb - 

     

    Is your screen display scaling set to 100% for any laptop/monitor screens you have open? If its not i suggest you change to 100% and try again. 

     

    Let me know if this helps. 


    Emma

    • sothqamb's avatar
      sothqamb
      Occasional Contributor

      I am working remotely currently and have no way of changing/looking at any desktop scaling, but i doubt the scaling would be at anything but 100% as the computer is relatively new and i have never changed the scaling. If you have any other suggestions send them my way. Thanks!

      • ebarbera's avatar
        ebarbera
        Staff

        Hi sothqamb - 

         

        Even with a remote machine you can check the display settings. By default they are not always set to 100% so I would still suggest this as your first approach. It also could have to do with how you are using the browser in the smaller size. For this i would suggest running the TestComplete "Run Virtual Browser" operation to re-size the browser - to make sure TestComplete can properly identify elements within the re-sized window (https://support.smartbear.com/testcomplete/docs/keyword-testing/reference/web/run-virtual-browser.html)

         

        Let me know if you have additional questions. 

         

        Emma