cancel
Showing results for 
Search instead for 
Did you mean: 

TC doesnt map object names automatically

SOLVED
YuriSdev
New Contributor

TC doesnt map object names automatically

Hello, 

I am facing a problem.

New objects are not added to the Name Mapping. Now I see the 'Window("some_class", "some_name")' instead of the way it was before.
What am I doing wrong ?

 

1. An options

YuriSdev_0-1601358257749.png

 

2. When I recording and click on element now I get following:

YuriSdev_1-1601358337495.png

This should not be such way - Window(etc). Also previously this element would have been automatically added but now :

YuriSdev_2-1601358589796.png

 

1 ACCEPTED SOLUTION

Accepted Solutions
JuliaBernikova
Moderator

Re: TC doesnt map object names automatically

@YuriSdev@jaward916,

 

Thanks for reporting the issue. We would like to investigate it, so could you please contact our support team by creating a case here? We'll need the following information:

  • The project where the issue occurs. Also, please check if the same problem occurs in a newly created project.
  • The technology your tested application uses. Please also check whether the issue persists for every application or only for the one under test.
  • If you can record a short video demonstrating the issue, that will help a lot as well. You can use free tools like Loom or Jing for that.
  • Finally, we'll need a report - this way, our developers will be able to find out what's going on inside TestComplete when you observe the issue. Here are the steps to collect the report:
    1. Run Report Generator (<TestComplete>\x64\Bin\ReportGenerator.exe for the 64-bit TC version or <TestComplete>\Bin\ReportGenerator.exe for the 32-bit TC version.
    2. Choose an option that corresponds to your tested application type (I assume "When testing a desktop app") and follow the on-screen instructions.
    3. Reproduce the problem.
    4. Click the "Create memory dump" button.
    5. Click the "Save..." button - this will save the report into an archive. Send this archive to us.

If you need any help with collecting the mentioned info, just create a case - we'll assist you with that!

 

Julia Bernikova
SmartBear Customer Care Manager - TestComplete

View solution in original post

4 REPLIES 4
Marsha_R
Community Hero

Re: TC doesnt map object names automatically

  • Did your TC version change?
  • Are you working on a different machine than when the mapping worked?  What's the difference between the two machines?
  • Did your browser get updated?
  • Did your application get updated?
jaward916
Occasional Contributor

Re: TC doesnt map object names automatically

I have noticed this change too, I didn't see it as a major issue, but definitely a change in the last week or so. I guess update related, maybe a setting got reset, or mapping itself has been "improved". I wonder if having the Update Mappings option disabled will make this better or worse?

 

YuriSdev
New Contributor

Re: TC doesnt map object names automatically

This is testcompete desktop version.

I implemented this tests on PC1

then I continued my work on PC2 -everything was fine

then there were two, as I remember, TC upgrades, and now I got this problem. Also now not only me faced with this as could be seen from last comment

JuliaBernikova
Moderator

Re: TC doesnt map object names automatically

@YuriSdev@jaward916,

 

Thanks for reporting the issue. We would like to investigate it, so could you please contact our support team by creating a case here? We'll need the following information:

  • The project where the issue occurs. Also, please check if the same problem occurs in a newly created project.
  • The technology your tested application uses. Please also check whether the issue persists for every application or only for the one under test.
  • If you can record a short video demonstrating the issue, that will help a lot as well. You can use free tools like Loom or Jing for that.
  • Finally, we'll need a report - this way, our developers will be able to find out what's going on inside TestComplete when you observe the issue. Here are the steps to collect the report:
    1. Run Report Generator (<TestComplete>\x64\Bin\ReportGenerator.exe for the 64-bit TC version or <TestComplete>\Bin\ReportGenerator.exe for the 32-bit TC version.
    2. Choose an option that corresponds to your tested application type (I assume "When testing a desktop app") and follow the on-screen instructions.
    3. Reproduce the problem.
    4. Click the "Create memory dump" button.
    5. Click the "Save..." button - this will save the report into an archive. Send this archive to us.

If you need any help with collecting the mentioned info, just create a case - we'll assist you with that!

 

Julia Bernikova
SmartBear Customer Care Manager - TestComplete

View solution in original post

New Here?
Join us and watch the welcome video:
Announcements
Top Kudoed Authors