Forum Discussion

leeasdf9's avatar
leeasdf9
Frequent Contributor
15 days ago

TestComplete15.63 is unable to recognize a range of standard html controls in Object Browser

Hi,

it seems that TestComplete15.63 is unable to recognize a range of standard html controls such as html textbox, pushbutton etc, please also see screenshot attached, compared with previous version TC15.49 where the controls are shown in Object Browser.

As FF115.4esr is officially supported by TC15.63, i suppose there might be something wrong in the configuration on my side, but i just tried all options of following instructions and no success:

Considerations for Web Testing | TestComplete Documentation (smartbear.com)

Preparing Firefox for Web Testing | TestComplete Documentation (smartbear.com)

 

any help would be much appreciated.

Thank you.

Lee

14 Replies

  • leftend86a's avatar
    leftend86a
    New Contributor

    Lee, I am having a very similar issue from the same situation.  TC cannot work on anything inside the browser window and objects are not appearing in the Object Browser. 

    It all started when I installed 15.63.22 x64 with FF 115.4 esr.   I submitted EXTERNAL: Case #00609596.  I was advised to 'check everything".  I have verified as you have and nothing was missed. 

    Jon Conyers

    • leeasdf9's avatar
      leeasdf9
      Frequent Contributor

      Hi Jon, thanks for sharing the information!! please keep the case open until you get some support from custom care. and please keep me updated in case you find out what is the solution. 

      thank you.

      Lee 

  • eykxas's avatar
    eykxas
    Regular Contributor

    Hi ! I have the same problem with Edge 124 (or Chrome). Every version of TC after 15.57 doesn't work properly. They don't detect certain DOM elements and their custom tags.

    I'm still running 15.57.

    • leeasdf9's avatar
      leeasdf9
      Frequent Contributor

      Hi eykxas, i would suggest to create a custom ticket, please keep me updated if you get a solution for the object issue. it deals most probably with same serious issue what i face with FF115.4. 

      Thank you.

      Lee

      • eykxas's avatar
        eykxas
        Regular Contributor

        Hi, I can't create a custom ticket. I mean, I could but it will be useless because I can't provide sufficient information / data to Smartbear. My company has many confidential data, and they don't like doing NDAs... So... I hope for someone else to find the problem.

  • leeasdf9's avatar
    leeasdf9
    Frequent Contributor

    thank you rraghvani,

    i can ensure you, after over 10years experiences with TC, i tried all options this time and no success.

    i will let this post open for a while and see if some other expert has encountered similar firefox control issue, if no i will create a custom care ticket later.

    thanks again.

    Lee 

     

    • Marsha_R's avatar
      Marsha_R
      Champion Level 3

      leeasdf9 If you have 10 years experience with TC, then you know that the message board is not psychic and rraghvani and the rest of us have no way to know what you've tried and what you haven't if it's not in your post. I can assure you that we start with the basics in our questions because many users have not tried all the recommended options before they post. 

  • DanNad's avatar
    DanNad
    Contributor

    We have similar problems with testcomplete 15.63. Testcomplete 15.63 couldnt find the URL of a lot of our mapped page objects. It was always showing an empty URL when viewed in object spy.

    We had to downgrade to TestComplete and TestExecute 15.57