Forum Discussion

mbeecham's avatar
Occasional Contributor
12 years ago

"Verification Failed... (user) is not logged in on the slave computer" - anyone seen this before?

I am trying to setup Distributed Testing and so have added detail in the Hosts section of Network Suite.

When I try to verify the connection, I get a message including “Verification failed… The user … is not logged in on the slave computer”.

The details entered into Host are all correct.

I have worked through the checks on the “Message – Verification Failed” section of the TestComplete Help.

The same details will launch and allow use of a Remote Desktop connection between the Master machine and the Slave.

If I alter the details (user/password) to something NOT correct, I get a different message so that confirms that the details used are correct.

I have tried it with the same user logged in on the slave, and without any user logged in on the slave.

I have Test Complete and Test Execute both installed on the Slave machine. If I start them up directly, they pick up their licencing from Licence Manager located on the Master machine; so that seems to prove the network connectivity is there.

The Master is a physical machine running Windows Server 2003 (64 bit, SP2), while the Slave is a VM (VMWare) running Windows Server 2008 (32bit, SP2)

3 Replies

  • tristaanogre's avatar
    Esteemed Contributor
    Copyied reply from other site:

    Hiya again, Mark! ;-)

    TestComplete, because of how it runs tests, requires the ability to interact with the desktop. If the virtual machine is running "minimized", it may not have a "desktop" to interact with and, while you may be able to use authentication to run the test "as" a particular user, that does not necessarily guarentee that the desktop is open and able to be interacted with.

    That's my best guess based upon experience... hope it helps.
  • mbeecham's avatar
    Occasional Contributor
    (same reply as on other site)

    Yes... aware of that bit, thanks.

    It's the "actually getting connected to the remote desktop" bit that's proving troublesome.
  • mbeecham's avatar
    Occasional Contributor
    After further experimentation, I have now found the answer:

    On one connection, the Verification was working fine... so working through the "Distributed Testing - Requirements" pages in the TestComplete Help, I compared all the settings between the working connection and the not-working connection.

    The Restrict each user to one session option on the Terminal Services Configuration was set to Yes on the working connection, but was set to No on the not-working connection.

    I changed it to Yes... and the verify then works!

    The " not logged in on the slave computer" error is not mentioned on the "Message - Verification Failed" help page so perhaps that could be tweaked to point towards checking the Restrict each user to one session detail?

    (Since I sorted it out, I have now also been able to run Jobs in a Distributed Test style... Everything is working well.)