Forum Discussion

acm's avatar
8 years ago

Text field (object) not being targeted by PropertyCheckpoint tool



First of all, do licensed TestComplete users (also) post their questions here?  Or is there a different channel for submitting a help ticket?


I am in need of assistance with using the Property Checkpoint wizard to validate that a text field (4-char) contains "1855".  It sure sounds easy enough but when I drag the target/bullseye over the text field, a much larger area of the browser gets highlighted in red.  How do I proceed or narrow down the object selection? Newbie here :(


p.s. I recorded a video using Jing to illustrate the attempt.


Thanks in advance.


  • Hi,


    Unfortunately, I am still unclear about the relationship between Object Browser and Name Mapping.  When should I be using the Object Browser versus Name Mapping?


    Kindly correct me if I am wrong... When keyword tests are recorded, objects are created and stored in the Object Browser(Name mapping).  But, at which point in time is the Name Mapping generated or requires my attention?(Name mapping contains objects that are being added via Record or Manually.)   Also, we the users have the ability to modify objects either in the Object Browser or Name Mapping? (You can do the Edit Name mapping not in the Object Browser)

    General concepts based on my understanding, 

    Object Browser:

    • Object browser contains all the process and its child objects displayed in the machine
    • It will not related with any of the Keyword Tests or Scripts
    • It is a place where we can see the AUT objects and what ever objects you want map for your tests you do by Right Click on the specified object and clicking Map Object option. and much more

    Name mapping:

    Best source would be 101 training session video


9 Replies

  • tristaanogre's avatar
    Esteemed Contributor

    First of all, yes, this forum us used by all TestComplete users.  This community is frequented both by SmartBear staff as well as other TestComplete users.  We share our experience with others and attempt to help them.  If you'd prefer a direct trouble ticket from SmartBear you can go to and submit a ticket there but we might be able to help you here, first.


    As shankar_r mentioned, there are some things that you might need to do first before you can do the spying you want to do.


    Question: What is this site written in?  Is it a Flash/SWF application?  If so, there are some things you might need to do as well.


    As a secondary possibility, you can try and find the component in the Object Browser itself.  Once you find it there, you can copy the application path of the object to copy into a Property Checkpoint.  Also, IIRC, property checkpoints typically automatically map components so you can even right click on the object in the object browser and select "Map Object" to add it to your name mapping directly.

    • acm's avatar

      Hi Robert,


      Re: All users in the forum, that's wonderful.  Good to know.


      I am in the process of confirming all of the languages/technologies used. So far, I do know that Knockout.js is one of them and that there is no Flash involved.  Attaching a screenshot with some of the source code of the "text" element I wish to create a Property Checkpoint for.



      Re: the secondary possibility of finding the component in the Object Browser itself.  Is there a video available that demonstrates the steps?





      • acm's avatar

        Here's another screenshot that actually shows the element as input type = hidden.


    • acm's avatar

      Hi Shankar,


      Thanks for the reminder.   I have read through Chrome browser setup doc and took the necessary steps.  My browser  is also at 100% zoom.




      • HKosova's avatar
        SmartBear Alumni (Retired)

        Hi Arlene,


        On your original video, the browser zoom was more than 100% - as indicated by the (-) button in the address bar. Once you set it back to 100%, the object recognition should work fine. Can you try the Object Spy again now that you use 100% zoom?