Forum Discussion

bewen's avatar
bewen
Occasional Contributor
12 months ago

TestComplete thinks im running on a virtual machine

Hi, im trying to load up TestComplete on my system, I have a fixed license to be able to use TestComplete. Everything was working fine yesterday, but today TestComplete is saying I am running the application on a virtual or cloud machine even though its on my actual system so im required to use a floating license. Has anyone else come across this issue and know how to fix it? I have also tried restarting my system but it still appears when TestComplete is loaded.  

 

Hyper-V Also is disabled

 

11 Replies

    • pstjohn's avatar
      pstjohn
      Occasional Contributor

      Is it just me or does anyone else find the limitation of not being able to run TestComplete with a fixed license on a system with virtualization enabled ridiculous?  The licensing page says I can't use a fixed license if running on a VM, but doesn't tell say anything about virtualization simply being enabled. The 'error' message also does not indicate this. 

      I guess it's just crazy to think a developer or QA tester would have any need to run VMs....

      • Marsha_R's avatar
        Marsha_R
        Champion Level 3

        Floating licenses work fine and you can always just keep it to one user. 

  • rraghvani's avatar
    rraghvani
    Champion Level 3

    A Fixed User license cannot be used on physical computers that have Hyper-V enabled. To run TestComplete, you can use a Floating license, or you can disable Hyper-V via

     

    • pstjohn's avatar
      pstjohn
      Occasional Contributor

      Yes, that is the workaround (and what I did).  Love the workflow of having to turn off a Windows feature and reboot my computer if I want to run TestComplete (or spend thousands more).  

      And while I still think the limitation is silly for a common configuration it is certainly at least worthy of mentioning in all the same places that not being able to run on VM is mentioned.