Forum Discussion

Mark1's avatar
4 years ago

Testcomplete Stuck On "Initializing" Screen

Having an issue where when running a project with a remote pc, it can get stuck on the Initializing screen as shown in the screenshot below. It does not get stuck every time I run the project, I would say its about 50/50 whether it runs or not. If it gets stuck, it will not move past it, I have left it for hours and still no progress.


I have at least a hundred other scripts in this project that work fine, it is only this one where it gets stuck, the only difference between this script and any other is it has quite a few references to other scripts ('USEUNIT x), more than any other script I have, which I can verify by splitting the script up but I can't get to that until later, but I would be surprised if that was the issue.


2 Replies

  • Mark1's avatar

    Splitting up the script into two smaller ones and splitting the references between them seemed to have worked at first but it must have just been some good luck as it didn't take long for the issue to occur, so I am out of ideas. Any help would be appreciated.