Forum Discussion

CreeTar's avatar
New Contributor
15 years ago

TestComplete does not recognize Application Window

Hello there,

I am currently evaluating the trial and my problem is that the current TestComplete does not even recognize the window of the application. The application has many modules, each has its own window with GUI and a process and none of them is recognized. I was hoping the Keyword Test Recorder would at least recognize the strings of a window, but it recorded nothing at all.

The program I was testing is TuneUp Utilities 2010 (, which is using some sort of HTML content in their windows.

My first attempt was using AutoIt which allows to identify windows by title and buttons by text and I was successful with that and now I tried to take it one step further with a more professional test environment, but it seems that this is already too complicated for TC?!

Has anybody some advice what I could try, may be some plug ins or probably another suite?



4 Replies

  • Hi Alexander,

    I have found out that TestComplete can recognize individual objects of the trial 9.0 version of the TuneUp Utilities application. Make sure that the Web Testing plug-in is installed and enabled (select "File | Install Extension..." from the main menu). If the plug-in is enabled and the problem still persists, please send me the recorded script/keyword test (zip the entire project suite folder) via our Contact Support form. Also, let me know what Internet Explorer version and OS you are using.
  • CreeTar's avatar
    New Contributor
    Hi David,

    thanks for your quick reply. I already made a ticket with your link and attached the project.

    Thanks for the help.

  • Hi Alexander,

    Have you tried running TestComplete with administrator permissions as it was suggested in our reply sent to you on April 9?
  • CreeTar's avatar
    New Contributor
    Hi David, thanks that was the problem. Now I can further evaluate :)

    If I have further questions, can I just post them here?

    For instance, I want to click a button, it is recognized from TC via the Object Browser,

    the Finder Tool though does not recognize it when hovering over it (its a button behind an image)

    if I execute below using

    Call Sys.Process("Integrator").VCLObject("frmNag").VCLObject("Panel1").VCLObject("btnFour").ClickButton()

    I get that the window is invisible, though its actually a button and the Window frmNag is visible.

    This is just a test for my understanding, if its possible to test our internal HTML controls of the software.

    So if this is too much to ask I do understand.