Forum Discussion

MicSwaTaco's avatar
MicSwaTaco
Occasional Contributor
11 months ago

TC running on Windows within Parallels VM on MackBook Pro M1

Is anyone else running TestComplete on a MacBook M1 with the Parallels VM with Windows running in it?  I have loaded the Appium Server on the MacOS cmd-line and tried the Appium Server GUI via Windows, that actually runs on the MacOS.  I am not able to connect to my iPad that is running and attached via USB to the MacBook but linked to the Windows instance. I have followed the SmartBear with Appium Server documents and procedures a couple of times and with the Support people with no change. I am running a Local BitBar link instance to the remote device via the base IP 127.0.0.1 and MacBook IP.  I have tried both the Appium level 1.x and 2.x with no difference. The parameters I have used within the JSON part are 'automationName-UICTest driver', 'deviceName-Apple iPad' and 'platformName- iOS'. Tried using the UDID, what showed up as the serial number on MacBook devices and the properties of the iPad, which was different. Neither worked. 

We (SmartBear Support and I) are researching and checking setup along with the errors experienced. 

 

As a side note: I have been running this way on my Windows laptop with TestComplete to a USB attached Android tablet for months.

 

I thank anyone and everyone that has experience or suggestions.  Thank you. 

No RepliesBe the first to reply