Forum Discussion

nastester's avatar
nastester
Regular Contributor
4 months ago

Suppress Security Warning when running Tested Apps

When running a .cmd file that is on a network drive via Tested Apps I am encountering this Security Warning.

I need a way to suppress this popup as it currently requires manual intervention of the automation.

I see this thread: https://community.smartbear.com/discussions/testcomplete-questions/open-file-security---warning-popup/204357

But I wanted to revisit to see if there is a better way to handle this.

 

 

3 Replies

  • Matthias68's avatar
    Matthias68
    Occasional Contributor

    We have UAC turned off, but the security message still comes up when the batch file is opened normally on the network.

    However, the following approach works for us:
    We create a local batch file that directly calls the batch file located in the network.
    The call is then made using the following sequence:
    // 1. Change to the directory of the batch file on the network
    WshShell.CurrentDirectory = comVariableStorage.getVariable("Dir");
    // 2. Call the local batch file
    WshShell.Run(fwConstants.BatchDir + "\\start_appl_xxx.bat");

    Result: no security message appears anymore

  • Marsha_R's avatar
    Marsha_R
    Champion Level 3

    I would follow the instructions in the previous thread. That way you don't have to change your settings on every test computer. If you decide to change the settings, make sure that your organization doesn't have security requirements that would be violated by doing that.

  • You need to change windows settings, you can do that by opening UAC settings and set the value to never notify as shown in below screen capture.