Forum Discussion

PhilipF's avatar
PhilipF
Occasional Contributor
9 months ago
Solved

SoapUI 5.7 & 5.6 MacOS Installer and multiple libprism warnings: "will damage your computer"

Hello All.  I've got an Apple M1 Max running Ventura 13.4.1 and am unable to get SoapUI to work.

 

Whenever I run the SoapUI-5.7.0.app, I get multiple warnings that various libprism components of the app "will damage your computer".

 

Clicking "Cancel" pops up the next error and after the last one the app launch fails and everything closes (or is closed by MacOS?).

 

I initially wasn't even able to open the installer .dmg file.  I had to use DiskUtility to mount the image in order to run the installer App.  Then the installer App gave this error message: 

 

I was able to get around this by selecting “Get Info” from the context menu.  In the Info window that appears, expand the “General” information, check the box next to “Override Malware Protection”.

 

But now, the app won't run at all.  I've tried this with the current version, 5.7, and previous version.

 

How can I get up and running with SoapUI?  And why is MacOS barking about the libprism components - are they safe?

 

Thanks

18 Replies

  • eric-flash's avatar
    eric-flash
    Regular Visitor

    Same issue here, used to work a few days ago and stopped now: 

     

  • javier4c's avatar
    javier4c
    Occasional Visitor

    Hello

     

    Same issue, the thing is I don't have the option “Override Malware Protection”, in MacOS Sonoma 14.0.

     

     

    • PhilipF's avatar
      PhilipF
      Occasional Contributor

      Same for me.  The "Override Malware Protection" was something I was only able to do on the Installer.

  • DylanVH's avatar
    DylanVH
    Regular Visitor

    Same issue for me, I got the 4 error messages and couldn't open Soap.

    Then I tried to reinstall Soap but it won't install.

    Waiting for a solution