Ask a Question

What? "The SkypeHost.exe process crashed"


What? "The SkypeHost.exe process crashed"

I'm authoring test scripts for an application which has nothing to do with Skype, of course, yet I receive intermittent errors in my test log saying "The SkypeHost.exe process crashed." Not even the name of the tested application begins with "S". Let's call the tested app Northwind, and its manufacturer Contoso.


So, even more interesting, the error is rather intermittent and is bound to very different code lines. If I double click the entry in the log, sometimes it takes me to an aqString.Replace method:

folder = aqString.Replace(folder, "\\\\", "\\"); // Now path is ending with exactly one blackslash

At other times, it takes me to different, apparently random code lines, such as tryin the next one:

Aliases.Northwind.DocumentListInLocalProject.WPFObject("HierarchicalListViewItem", "", 1).WPFObject("ContentPresenter", "", 2).WPFObject("Border", "", 1).WPFObject("DockPanel", "", 1).WPFObject("DockPanel", "", 1).WPFObject("TextBlock", DocumentName).Click();

The additional details refer to a dump file created by TC. which can be opened in Visual Studio. I've opened it in Visual Studio and used its Copy all command to put all the info to a text file. I only changed the real vendor name to Contoso, and the real app name to Northwind. I've attached this textual dump in the hope any of you can find valuable information in it.


I'd even happy to learn what may cause TC to recognize a 3rd party application's crash in general? (Of course, Skype and SkypeHost is not even a tested app in my projects.)


I noticed this line.

SkypeHost.exe C:\Program Files\WindowsApps\Microsoft.Messaging_1.11.19004.0_x86__8wekyb3d8bbwe\SkypeHost.exe


Our office uses skype as part of the MS Office package for internal instant messaging. Somehow it appears TC is looking at your messaging program. Perhaps the messaging program was running when the script was recorded and somehow affected the script.

Is there any way to find it somewhere? The name mappings shall and do not contain it. If I run a full-text search in Total Commander on the top folder containing my TC project suite, I only get hits for the term "skype" in he dmp files created for this event.


Actually most of the scripts were written manually in JScript. It contains a few lines converted from keyword scripts. There is clearly no indication of Skype in those steps, so I'm somewhat clueless as to how to find what to delete and from which file in order to get rid of this error.


same error here. are there any solutions?

viva la software ergonomica!
Showing results for 
Search instead for 
Did you mean: