Ask a Question

Unable to run test through Remote Desktop Connection in minimized mode

SOLVED
Mohit_Dadhich
Occasional Contributor

Unable to run test through Remote Desktop Connection in minimized mode

Hi,

 

I am trying to run tests through a Remote Desktop Connection but on minimizing the window GUI gets disabled and so the tests fails.

I have tried editing registry setting as said in https://support.smartbear.com/testcomplete/docs/testing-with/running/via-rdp/in-minimized-window.htm... but the problem persists.

Please have a look at the attachments

1 ACCEPTED SOLUTION

Accepted Solutions
Mohit_Dadhich
Occasional Contributor

Re: Unable to run test through Remote Desktop Connection in minimized mode

This issue has been resolved now.

Solution - Registry Entry was opened in local computer while running the scripts from remote desktop machine. I have closed the all the remote desktop connections, updated the registry entry and closed it. Then i retried and it worked.

View solution in original post

5 REPLIES 5
Marsha_R
Community Hero

Re: Unable to run test through Remote Desktop Connection in minimized mode

Here are some more setup steps that you need

https://support.smartbear.com/testcomplete/docs/testing-with/running/via-rdp/overview.html

Marsha_R
[Community Hero]
____
[Community Heroes] are not employed by SmartBear Software but
are just volunteers who have some experience with the tools by SmartBear Software
and a desire to help others. Posts made by [Community Heroes]
may differ from the official policies of SmartBear Software and should be treated
as the own private opinion of their authors and under no circumstances as an
official answer from SmartBear Software.
The [Community Hero] signature is used with permission by SmartBear Software.
https://community.smartbear.com/t5/custom/page/page-id/hall-of-fame
Mohit_Dadhich
Occasional Contributor

Re: Unable to run test through Remote Desktop Connection in minimized mode

The steps suggested has already been incorporated and still i am facing the same issue.

Marsha_R
Community Hero

Re: Unable to run test through Remote Desktop Connection in minimized mode

What version of TestComplete are you using? 

Does Remote Desktop work for you if it is not minimized?

Have you been able to work with Remote Desktop in minimized mode before or is this the first time?

Marsha_R
[Community Hero]
____
[Community Heroes] are not employed by SmartBear Software but
are just volunteers who have some experience with the tools by SmartBear Software
and a desire to help others. Posts made by [Community Heroes]
may differ from the official policies of SmartBear Software and should be treated
as the own private opinion of their authors and under no circumstances as an
official answer from SmartBear Software.
The [Community Hero] signature is used with permission by SmartBear Software.
https://community.smartbear.com/t5/custom/page/page-id/hall-of-fame
Mohit_Dadhich
Occasional Contributor

Re: Unable to run test through Remote Desktop Connection in minimized mode

Version of TestComplete - 14.91.341.7 x64

Yes, it is working perfectly fine if remote desktop is not minimized.

This is the first time i am working with remote desktop in minimized mode but i have made all the necessary changes as mentioned in the article

Mohit_Dadhich
Occasional Contributor

Re: Unable to run test through Remote Desktop Connection in minimized mode

This issue has been resolved now.

Solution - Registry Entry was opened in local computer while running the scripts from remote desktop machine. I have closed the all the remote desktop connections, updated the registry entry and closed it. Then i retried and it worked.

View solution in original post

cancel
Showing results for 
Search instead for 
Did you mean: