Ask a Question

Unable to access jarfile agent.jar

Occasional Contributor

Unable to access jarfile agent.jar


After creating a Node as instructed by the documentation to connect to Jenkins, the documentation says to follow the instructions to launch Jenkins agents to nodes and connecting them to Jenkins however, when I run the code in the command line I get the error: Error: Unable to access jarfile agent.jar.

Any suggestions on how to fix this?

Documentation I was following:


Hi @steventwerd 


I hope you are well. 


Can you send a screenshot of the error? 


JAR file config issues are generally due to the path not existing or changing. 


Have you cross checked the location of the JAR file and verified that the arguments used /location specifed are valid? 


Also would you have changed the xml 


Do you know if you have changed the location of the JAR file ? 


Sorry for all the questions but it might uncover why this is happening for you 





Occasional Contributor

Hi Vincent,

Please see the screenshots below:

There are 3 screenshots of the command prompt after entering the command given to me by Jenkins, a screenshot of Jenkins telling me to put the command into the command prompt and a screenshot of the directory that I am using as the remote root directory.





Just a guess: what if you change 'java -jar agent.jar ...' to 'java -jar C:\Jenkins\agent.jar ...' ?


  /Alex [Community Champion]
[Community Champions] are not employed by SmartBear Software but
are just volunteers who have some experience with the tools by SmartBear Software
and a desire to help others. Posts made by [Community Champions]
may differ from the official policies of SmartBear Software and should be treated
as the own private opinion of their authors and under no circumstances as an
official answer from SmartBear Software.
The [Community Champion] signature is assigned on quarterly basis and is used with permission by SmartBear Software.
Occasional Contributor

Hey Alex,


Thank you, that has solved my problem and the agent is now connected. Thank you, you truly are a Community Hero. xD



Showing results for 
Search instead for 
Did you mean: