Ask a Question

The tested window (or control) has been deleted

Established Member

The tested window (or control) has been deleted

After the upgrade to latest version of test complete I'm getting the error -"The tested window (or control) has been deleted"

When I run any test it just opens the browser do the first action and closes the browser with above error. 

Test Complete Version: x64

Chrome Version 113.0.5672.93



hi @Kavina 


Could you please try disabling Hardware Acceleration under Chrome Settings > System?

If that does not work, try re-installing Chrome. I saw a similar issue recently where this resolved this issue.


Let me know if this does or does not work. 





I am having the exact same issue.



I have had this issue with both TestComplete and The version of Chrome does not seem to matter - we see the same issue with both Chrome 112 and 113.


TestComplete 15.50 does not have this issue. We have rolled back to 15.50 until this issue is resolved in TestComplete. 


@mikef I have tried turning off hardware acceleration as you suggested, and it made no difference. I still see the same error message.


Problem is in last version of Chrome 113* (or in Testcomplete with last version Chrome).

@A_Roskoshnyi No, it is not. We experience the same issue when running Chrome 112. The issue is entirely with TC 15.51.


Just to reiterate / clarify, as there has been no movement on this issue yet:

TestComplete x64 is working for us with Chrome 113.0.5672.127 (latest update to Chrome at the time of this post).

TestComplete 15.51.x.y is not working for us at all with any browser or browser version.

Champion Level 2

Just to cross-reference that others also have this problem (which seems to be either not resolved yet, or be a regression):


  /Alex [Community Champion]
[Community Champions] are not employed by SmartBear Software but
are just volunteers who have some experience with the tools by SmartBear Software
and a desire to help others. Posts made by [Community Champions]
may differ from the official policies of SmartBear Software and should be treated
as the own private opinion of their authors and under no circumstances as an
official answer from SmartBear Software.
The [Community Champion] signature is assigned on quarterly basis and is used with permission by SmartBear Software.
Regular Contributor

wanted to provide an update on recent developments. When I first opened up testcomplete this morning I got the notification that a new release/build was available so I downloaded and installed it. my web apps still did not work. At the suggestion of Alex Karras, I uninstalled testcomplete 15.51 and downloaded the install package for 15.49 and put it on my workstation. Now my web apps are working. My concern now is that, since I have also updated the testexecute apps on my VM’s to 15.51 will testcases I develop on my workstation with 15.49 be able to run? clearly something has changed about the newest releases of testcomplete that are causing this issue.  when is smartbear going to address it? 

@joe_brooks wrote:

TestComplete 15.51.x.y is not working for us at all with any browser or browser version.

What exactly do you mean when you say "not working at all"? TestComplete doesn't recognize anything in Chrome? Does it view Chrome as just a big red box in Object Browser? 


Or, do you mean the "Control has been deleted" issue is not working at all?

Showing results for 
Search instead for 
Did you mean: