Ask a Question

Testcomplete not "see" object of Android app in "Object Browser" after "adb shell am force-stop"

Occasional Contributor

Testcomplete not "see" object of Android app in "Object Browser" after "adb shell am force-stop"

Hi All!


I ran into the following problem:

If I run the "adb shell am force-stop <PACKAGE>" command while the script is running and run the Android app again with the "am start-n yourpackagename/.activityname" command, then the app is no longer visible in the "Object Browser" tab.


Two points are also known:
1. the command " ... am force-stop .. "stops all child processes associated with the running package, which means that "your "(with the prefix". tctest") application also stops working

2. When I start the application via "TestComplete", then " TestComplete":
2.1 repackages "my" app in " apk"
2.2 creates an additional application "instrumentation-signed. apk" ("your")
2.3 installs these two apps on the device while removing the two apps from the computer at the same time
2.4 somehow runs both apps, so that "my" re-packaged app will run through " yours"


So I have questions:

1. What is the best way to stop the app so that the connection between "my" re-packaged app and "your" app is not lost?

2. If I have "my" repackaged application and "your" application, in what order and with what commands do I need to launch the applications so that after launching "my" repackaged application, the objects are visible on the "Object Browser" tab?



make a human work with the tested Android application from the "TestedApp" module-give opportunities:
1. Launch the app (with a full cycle of operation)
2. Run only the app (without instrumentation, just run and that's it)
3. Deploy the app (with a full cycle of operation) without starting
4. Deploy only (without instrumentation, just deploy and that's it)
5. Stop the app (just stop and that's it)
6. Restart the app (just restart and that's it)
7. Delete the app (just delete and that's it)

Let this functionality be available only from the script.



My env:

PC: Win10x64, ru

Android Studio: 4.0.1 x64

TestComplete: 14.71 x64



SmartBear Alumni (Retired)

Hi @C-Hansen ! No news from me, unfortunately. Please do create a support case, looks like this needs to be investigated by the support team.

Sonya Mihaljova
Community and Education Specialist

Showing results for 
Search instead for 
Did you mean: