Ask a Question

TE does not see libraries and files inside the project


TE does not see libraries and files inside the project

My project structure includes a .py file with 'test steps' and a .py file with step definitions. I did not make any changes in the project structure, but all my tests fail with errors indicating that my 'steps' are not defined. It also says that some libraries are missing, but they are in place. And it worked fine just couple of days ago. 

The issue appears on virtual machine with Test Execute. The same project works fine on my host machine.

It happened before, but I don't remember how it was solved (maybe it just had gone...)... I did an install repair for TE,but it did not help.


Any ideas?

Esteemed Contributor

Question: Are you running this as part of a distributed test within TestComplete or is this a TestExecute stand-alone session on your VM?

Robert Martin
[Hall of Fame]
Please consider giving a Kudo if I write good stuff

Why automate?  I do automated testing because there's only so much a human being can do and remain healthy.  Sleep is a requirement.  So, while people sleep, automation that I create does what I've described above in order to make sure that nothing gets past the final defense of the testing group.
I love good food, good books, good friends, and good fun.

Mysterious Gremlin Master
Vegas Thrill Rider
Extensions available

I'm not sure I know anything about distributed test... but there is no TC installed on this virtual machine. TE only.

Community Hero

First of all be sure that they are installed on the TE machine.

What libraries are you talking about?

How do you import them in your test scripts?



Champion Level 3



Does this thread help: ?

  /Alex [Community Champion]
[Community Champions] are not employed by SmartBear Software but
are just volunteers who have some experience with the tools by SmartBear Software
and a desire to help others. Posts made by [Community Champions]
may differ from the official policies of SmartBear Software and should be treated
as the own private opinion of their authors and under no circumstances as an
official answer from SmartBear Software.
The [Community Champion] signature is assigned on quarterly basis and is used with permission by SmartBear Software.

Guys, the problem is that the project STOPPED working.

I did not import anything new or changed anything.


TE STOPPED seeing method definitions imported from another .py file inside the project.

That means my statements:

'import requests '


'from my_second_file import *'

stopped importing anything.


TE says 'no module named requests' and 'some_my_method is not defined' (for all methods)


The same project works fine on my host machine (also did not change anything here).


Community Hero

Something HAD to change. Software doesn't change itself. 


Have you tried re-copying your project from the known working machine to the VM?


Are you using any kind of source control that you could revert to a previous state?


Click the Accept as Solution button if my answer has helped

Both machines use the same code (via Git).

The only difference is that my host machine executes it with Test Complete, and my virtual machine - with Test Execute.

Community Hero

Do you have an original Python interpreter installed on your machines (I mean another than built in TestComplete/Execute)?

Showing results for 
Search instead for 
Did you mean: