Ask a Question

Object recoginition completely failing

Occasional Contributor

Object recoginition completely failing

Hi all,


It's been a while since I've used TestComplete and our maintenance subscription has lapsed. I have an urgent need to fire it up and rerun some tests I wrote a while back but for some reason the software is refusing to see Firefox as a browser. It'll find and interact with Chrome but will open Firefox but then says Sys.Browser cannot be found.


I have completely reinstalled TestComplete 14 and let it update the Firefox and Chrome modules but to no avail. What I did notice is that if I attempt to map a new object using the point and click approach, it only selects/highlights the entire window in red. Nothing inside it. I tried this on both Firefox and Chrome.


I then thought it might be due to me accessing this installiation over RDP. So I've installed it locally and have exactly the same issue, it will not select any objects on screen at all.


Am I missing something really obvious?


Many Thanks!





what version of Firefox are you running? 


Have you checked and ensured firefox is prepared for web testing using Testcomplete?


Also when your running tests on firefox,are using a loop or a standard run browser operation?

Occasional Contributor

Version 77 but I tried downgrading to 76 and same issue.


Only thing I didn't have was the Environment Variable which I hadn't needed in the past but this has made no difference unfortunately. If I try to highlight any object I just get the Window and none of the inner objects get highlighted.


I've not even got to the point of running the tests yet. I can get TestComplete to open Firefox but it doesn't navigate to the URL specified. If I change that line to alter btFirefox to btChrome it opens Chrome and navigates to the URL. But I cannot pick an object using the Name Mapping Add Object picker in any browser.


If I simply have a test that tells an instance of firefox to open, then on the next line asks it to navigate, it opens Firefox but then the navigation fails and I get this.



Which version of TestComplete 14 are you using?  Depending upon the version and the versions of Firefox and Chrome, you may need to patch it.


For Chrome, you can check here for the appropriate patch.


For Firefox, check here.


Note that for Firefox, patches are ONLY available for TestComplete 14.40 so if you're running an earlier version of TestComplete, you will need to contact SmartBear support directly.

Robert Martin
[Hall of Fame]
Please consider giving a Kudo if I write good stuff

Why automate?  I do automated testing because there's only so much a human being can do and remain healthy.  Sleep is a requirement.  So, while people sleep, automation that I create does what I've described above in order to make sure that nothing gets past the final defense of the testing group.
I love good food, good books, good friends, and good fun.

Mysterious Gremlin Master
Vegas Thrill Rider
Extensions available
Occasional Contributor

I think you've hit the nail on the head, I have 14.20.2175.7 as this is the latest we can use. But the software itself has already downloaded those patches as they exist. I would have expected it not to even download them automatically if it couldn't use them. Thats a shame!


I'll have to speak to our accounts team as they didn't renew due to not knowing if we were going to use the product anymore but I assumed I could still use it on the older version for now, but it seems not.


Showing results for 
Search instead for 
Did you mean: