Ask a Question

ClickItem only works once per test

Occasional Contributor

ClickItem only works once per test

I know ClickItem has been having issues since 15.51 came out, so we have been running 15.49. 


I saw 15.52 is out so I figured I would give the latest a try. I am on x64.


I am still having trouble with ClickItem failing to run on my tests. It seems that it is only happening if you run a ClickItem command on the same ComboBox in the same test.


If I run a test that only touches that combo box a single time, it works fine.


If the test clicks on the combo box (to open the list) then tries to do a ClickItem it fails. If I disable that click before the ClickItem it works fine.


If the test runs a ClickItem on a combo box it works, then if the same test tries to circle back and tries to run another ClickItem it fails with this error:

An error occurred.
Possible reasons:
1. The application stopped responding.
2. The application was compiled incorrectly (see the Open Applications topic in the help system).
3. An error occurred in TestComplete/TestExecute.

Technical information:
515 0x80020003 (Member not found.) .
I verified the ClickItem command is not incorrect by disabling the first interaction with that combo box, now the command that was failing works fine, but of course the test fails on the 3rd attempt to interact with that combo box.


Anyone else seeing a similar issue?


Edit: This is on a .Net Windows Application

Champion Level 3

It's most likely the same issue. See


Since it's a Windows application, it's worth raising TestComplete: New Support Request

Occasional Contributor

I actually just opened a ticket as well, hopefully they can figure it out. They have been having ClickItem issues for over a month now.

Occasional Contributor

In case anyone was following along. I was told that the next update should fix this issue. It was supposed to be out on 7/5/2023 but does not look like that happened. I will try to remember to update this post when the update releases and I can verify my issue is resolved.

The 15.53 update does not appear to have fixed this issue.

Occasional Contributor

I reached out to support and on Friday they were able to give me a patch to manually apply that fixed this issue for me.


It sounds like this will be resolved in the next major update in a couple weeks. 8/7/2023 is what was mentioned in my communication with support.

New Contributor

Would someone be able to confirm that this issue is fixed in B15.54? I have reverted my build back to 15.50 as we are having so many issues with our tests and I would like to know if this is working in the latest build first before I update my version. Thank you.

Champion Level 3

I reported this issue about a month ago, and it still doesn't work in the latest version of TC v15.54.3.7 as shown in the video 🙄

Showing results for 
Search instead for 
Did you mean: