TestComplete

Reply
Occasional Contributor

TestComplete upgrade for chrome v63

After every few months due to Chrome updates we have to update TestComplete. Having a node lock license its a pain. I end up spending hours for each upgrade running into new issues every time no matter how carefully done.The process I use for new release:

 

Deactivate license
Uninstall TC (if version change instead o patch, e.g. 10.6 -> 12.1)
Upgrade new version
Activate license

 

Some of the problems I run into:
- License does not deactivate -
- Have to do offline deactivation,
- then offline deactivation does not work,
- then when it does complete finally, it does not deactivate on my licence page.

- Sentinel (the license manager) with TestComplete does uninstall correctly, restart the VM and do the whole process again

- Then sometime we run into problems with regenerating licenses
- Then it does not activate, have to do offline activation sometimes.

 

We have 5 VMs and I start getting nightmares when I have to upgrade.

 

Community Hero

Re: TestComplete upgrade for chrome v63

Hi,

 

You don't need to deactivate the license to upgrade TestComplete. 

You even can upgrade it over the old version.

Or I misunderstood something?

Occasional Contributor

Re: TestComplete upgrade for chrome v63

Well, as per the general process we should not have to, but for some reason I have ran into problems when the license was not deactivated first.

 

For instance, if the installation process gets jacked up somehow (which it does very easily since last two upgrades), you would have to deactivate the existing license first, which then becomes a huge problem. So I found it better off to deactivate it already Just In Case.

Occasional Contributor

Re: TestComplete upgrade for chrome v63

So after doing the last upgrade, here are the steps when I followed did not run into a roadblock:

 

  • Deactivate the license. If you have to go through manual deactivation, I don’t have a solution for that
  • Important: Once deactivated, confirm the license has been deactivated on your SmartBear account’s license page. If the license is not deactivated and you uninstall, that’s going to take some time to rectify
  • Restart the machine / VM (so the license manager service is not running)
  • Uninstall TestComplete
  • Upgrade Chrome in case it is not updated yet to latest version
  • Restart the machine / VM
  • Install the new TestComplete version
  • Activate the license
  • Run Chrome and make sure the TestComplete extension is enabled
  • If not, go the Chrome patch page on SmartBear’s website and download the latest patch for TestComplete and Chrome version, install it and test again

Again, this is not the way suggested by SmartBear's support, but by hit and trial this is what I have found to cause less problems.

Highlighted
Community Leader

Re: TestComplete upgrade for chrome v63

So you've contacted Support about this or are you just working from the support pages?

 

I would bug Support directly until you get a better resolution than this.  I've never had to go through that many steps to upgrade.

Occasional Contributor

Re: TestComplete upgrade for chrome v63

I did contact support, they helped out with the 'deactivation started' problem where the license would not deactivate, but did not mention a different flow for upgrading.

 

I've done these updates around 10 times since we have been using TestComplete (since v10.3), and each time there is a new problem I come across. The key here is if during upgrade the install hits a problem whih it usually does with the Sentinel licensing tool, that turns into a long story. I find it safer to deactivate and then upgrade. Since I have to do at least 5 VMs, eventually I do ruin into problems with at least on VM.

 

Another issue here I think is using a node lock on a VM, the licensing structure makes it really hard to upgrade in this configuration, for understandable reasons, but the user suffers too. 

Community Hero

Re: TestComplete upgrade for chrome v63

Hi,

 

Sounds weird as personally I never had upgrade problems...

 

> Another issue here I think is using a node lock on a VM

Might it be the reason of your problems? Node-locked license is not recommended to be used on VMs: https://support.smartbear.com/testcomplete/docs/licensing/license-types.html (Node-Locked License section).

 

Regards,
Alex
[Community Expert Group]
____
[Community Expert Group] members are not employed by SmartBear Software but
are just volunteers who have some experience with the tools by SmartBear Software
and a desire to help others. Postings made by [Community Expert Group] members
may differ from the official policies of SmartBear Software and should be treated
as the own private opinion of their authors and under no circumstances as an
official answer from SmartBear Software.
[Community Expert Group] signature is used with permission by SmartBear Software.
http://smartbear.com/forums/f83/t86934/community-experts/
================================
Join us to win gifts
Daily Articles: 1, 2, 3, 4, 5, 6, 7

Program Rules