cancel
Showing results for 
Search instead for 
Did you mean: 

Installation Error TestComplete.exe is running (Not all pre-installation conditions are met)

SOLVED
Mike359
Occasional Contributor

Installation Error TestComplete.exe is running (Not all pre-installation conditions are met)

Hi,

I am trying to install TestComplete.exe on a Windows7 Enterprise machine (v6.1 ServicePack1)

(I can see other posts that have experienced this, but cannot find any resolution)

Points to Note:

1. I have Administrator Privileges.

2. I keep getting the above error telling me TestComplete.exe is already running (but I have checked the task manager and it is not).

3. I have tried uninstalling first and it tells me - Unable to find TestComplete14 installed on this machine

4. I tried installing in Silent Mode to get a log and it output the following (Just added the last few lines)

    11:53:06: All operations are complete.
    11:53:06: Scenario player has finished playing all the scenarios.
    11:53:06: Start
    11:53:06: None of the known products is installed.
    11:53:06: IsUninstall: False
    11:53:06: Checking the installation environment
    11:53:06: TPreconditionsPage: Enter
    11:53:06: TPreconditionsPage: Check actual
    11:53:06: Proceed
    11:53:06: Finalize
    11:53:06: End
    11:53:11: Error message: "TestComplete.exe is running."
    11:53:11: Exit with code: 1

5. The machine is locked down with not much access to the outside world (for security purposes)

6. I am doing the install by Remote Desktop 

Any ideas as to what is going wrong? Should I log a support Issue?

1 ACCEPTED SOLUTION

Accepted Solutions
Marsha_R
Community Hero

Re: Installation Error TestComplete.exe is running (Not all pre-installation conditions are met)

You were correct in your earlier post.  You need an internet connection to install.

https://support.smartbear.com/testcomplete/docs/general-info/system-requirements.html

 

Marsha_R_0-1623856686436.png

 

View solution in original post

7 REPLIES 7
Marsha_R
Community Hero

Re: Installation Error TestComplete.exe is running (Not all pre-installation conditions are met)

Even with the installation error, does TestComplete run afterwards?

Mike359
Occasional Contributor

Re: Installation Error TestComplete.exe is running (Not all pre-installation conditions are met)

Hi Marsha, 

No the Install is halted, it is almost instantaneous. Nothing is installed (it is like the pre-install checks are failing).

(NB. If I try to uninstall after the message it tells me it could not find TestComplete to uninstall it)

It is also worth noting that this machine has no internet access is this a requirement ? (Unfortunately, I cannot add it to try it out)

Thank you for your response.

Kind Regards

Mike

 

Mike359
Occasional Contributor

Re: Installation Error TestComplete.exe is running (Not all pre-installation conditions are met)

I found this similar post for an issue in test execute that got resolved - I'll take a backup of the registry and see if I have something similar that I can remove.

   Re: TestExecute install fails with Error code -1, seeing previous installation even though not exist

   this worked:

   Our developers want you to remove the following keys before install new version of TE:

   Computer\HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\Windows\CurrentVersion\Uninstall{E1430B2E-6973-1440-8233-  724BAC44AAF2}
   Computer\HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\Windows\CurrentVersion\Uninstall\InstallShield_{E1430B2E-6973-1440-8233-724BAC44AAF2}
   Computer\HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\Windows\CurrentVersion\Uninstall{E1430B2E-6973-1450-8233-724BAC44AAF2}
   Computer\HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\Windows\CurrentVersion\Uninstall\InstallShield_{E1430B2E-6973-1450-8233-724BAC44AAF2}
   Computer\HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\Windows\CurrentVersion\Uninstall{E1430B2E-6973-1460-8233-724BAC44AAF2}
   Computer\HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\Windows\CurrentVersion\Uninstall\InstallShield_{E1430B2E-6973-1460-8233-724BAC44AAF2}
   Computer\HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\SmartBear\TestExecute\14.0

 

   Afterwards, try installing the latest release of TestExecute and see if the issue still occurs. 

I will update the post after I have tried it out

Thanks

Mike

Mike359
Occasional Contributor

Re: Installation Error TestComplete.exe is running (Not all pre-installation conditions are met)

Unfortunately that did not work.

I searched the registry and could not find anything similar or SmartBear related,

I checked I could Create a Registry key and value - all okay (I then deleted it okay)

I re-ran the install and got the same error here's the full log:

14:25:26:
14:25:26: Start
14:25:26: Computer: <I removed this from the log output>
14:25:26: Version: 14.74.437
14:25:26: Start
14:25:26: Proceed
14:25:26: Finalize
14:25:26: End
14:25:26: Start
14:25:26: Proceed
14:25:26: Finalize
14:25:26: End
14:25:26:    >>Reading the packed content...
14:25:26: Scenario count: 1
14:25:26: An empty scenario is detected.
14:25:26:    >>Waiting for background tasks to complete.
14:25:26:    >>Finishing...
14:25:26: All operations are complete.
14:25:26: Scenario player has finished playing all the scenarios.
14:25:26: Start
14:25:26: None of the known products is installed.
14:25:26: IsUninstall: False
14:25:26: Checking the installation environment
14:25:26: TPreconditionsPage: Enter
14:25:26: TPreconditionsPage: Check actual
14:25:26: Proceed
14:25:26: Finalize
14:25:26: End
14:25:31: Error message: "TestComplete.exe is running."
14:25:31: Exit with code: 1

 Definately nothing installed. Any other suggestions welcome

Marsha_R
Community Hero

Re: Installation Error TestComplete.exe is running (Not all pre-installation conditions are met)

You were correct in your earlier post.  You need an internet connection to install.

https://support.smartbear.com/testcomplete/docs/general-info/system-requirements.html

 

Marsha_R_0-1623856686436.png

 

View solution in original post

Mike359
Occasional Contributor

Re: Installation Error TestComplete.exe is running (Not all pre-installation conditions are met)

Thanks Marsha, your'e a gem 🙂 .I thought that might be the case, but could not see it in the requirements (but I'll check again)

 

Marsha_R
Community Hero

Re: Installation Error TestComplete.exe is running (Not all pre-installation conditions are met)

Thanks, that's always nice to hear!  I shall endeavor to remain shiny...   💎

New Here?
Join us and watch the welcome video:
Announcements