cancel
Showing results for 
Search instead for 
Did you mean: 

Is it possible to disable "Find this node on any level of NameMapping tree"?

SOLVED
Highlighted
Occasional Contributor

Is it possible to disable "Find this node on any level of NameMapping tree"?

When manually mapping new objects "Find this node on any level of NameMapping tree" is enabled by default.

 

Is there anyway to set the default to disabled?

 

We have a fairly extensive namemap and if enabled TC places the object somewhere buried in the parent hierarchy.  We then have to find it and manually drag it into the correct location and recreate the Alias.

 

This option is also applied automatically when TC prompts to map parent objects automatically.  Over time, the end result is an out of control namemapping tree.  Extended find is only used where necessary and in limited areas of our UI like dynamic grids or UI structure dependent on data.  It is useful but should not be used for every node.

 

I have disabled Extended Find in the name mapping options (See screenshot) but it still appears enabled.

 

We are using name mapping templates but there are no options there to control this either.

 

How can I disable this option?

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Occasional Contributor

Re: Is it possible to disable "Find this node on any level of NameMapping tree"?

Please disregard the above.  Sorted it.   The problem was the option "Use extended find when possible" was enabled and greyed-out due to the "Map object names automatically" being disabled. 

 

Steps:

"Use extended find when possible"  (Is greyed-out)

Enabled "Map object names automatically"

Disabled "Use extended find when possible"  (Not greyed-out)

Disabled "Map object names automatically"

"Use extended find when possible"  (Is greyed-out)

 

Got everything mapping normally now without extended find.

 

View solution in original post

2 REPLIES 2
Highlighted
Occasional Contributor

Re: Is it possible to disable "Find this node on any level of NameMapping tree"?

Please disregard the above.  Sorted it.   The problem was the option "Use extended find when possible" was enabled and greyed-out due to the "Map object names automatically" being disabled. 

 

Steps:

"Use extended find when possible"  (Is greyed-out)

Enabled "Map object names automatically"

Disabled "Use extended find when possible"  (Not greyed-out)

Disabled "Map object names automatically"

"Use extended find when possible"  (Is greyed-out)

 

Got everything mapping normally now without extended find.

 

View solution in original post

Highlighted
Community Manager

Re: Is it possible to disable "Find this node on any level of NameMapping tree"?

Hi jpr348, great to hear you solved this!  


Sonya Mihaljova
Community and Education Specialist

Learn SmartBear products in a fun and easy way and prove your knowledge!
>>Participate in the TechCorner Challenge today
New Here?
Join us and watch the welcome video:
Announcements
Join TechCorner Challenge!
Want a fun and easy way to learn TestComplete? Try solving weekly TechCorner challenges and get into the Leaderboard!


Challenge Status

Compare images using the Region Checkpoint

See replies!

Converting UTC TimeDate in an Excel file

See replies!

Compare HTML table with Excel file and correct data in Excel file

Participate!

How to execute remote test and obtain results via Test Runner REST API

Participate!
Top Kudoed Authors