Forum Discussion

Felixg's avatar
Occasional Contributor
6 years ago

When trying Click Action I get message Permission denied to access property in web testing on Firefo

Hi Everyone,


I have got a problem with the error message quoted in the title of this topic, I went through the community and found 3 topics dealing with a similar message but all solutions proposed did not solve my issue.


So, my issue is following : On Web-testing, when I perform a "Click" action on an object, I got an overlapped window with this message :

{ "mode": "callers", "name": "Error", "message": "Permission denied to access property \"firstChild\"", "stack": [], "incomplete": true }

You can found a screenshot of this window in attachement.


It causes a error message in log that is :

There was an attempt to perform an action at point (16, 16) which is transparent or out of the window bounds.

Precisions :

  • I targeted the "Click" action by running script in step by step debug mode.
  • The object that I try to call click action is found due to "FindChild" method and I can see it and check its properties in object browser. So, by setting a breakpoint on the click action line in script, I checked that during script running, all properties like "Exists", "Enabled", "Visible" and "VisibleOnScreen" are True when I try to perform the click action.
  • I got this error only in Firefox, my script is running well in Chrome, Edge, and Internet Explorer.
  • I run TestComplete as Administrator


More information about my configuration :

  • OS : Windows 10
  • TestComplete 12.50.4142.7 x64
  • Firefox ESR (64bits)
  • Scripting language : VBScript


Can someone help me or has any idea to go through this issue ?

  • Hi Everyone,


    Thanks to the SmartBear support I could go through this issue, so I share here what I have done if it can help someone.


    The issue should be corrected in release 12.60 of TestComplete, but you can temporary bypass this issue using the instruction :

    Sys.Browser.Page("*").contentDocument.Script.execScript("window.onerror = null")

    (in my case, it is VBScript code)


    Note that :

    • the wildcards "*" in the Page method will execute the script on the current loaded page, but you can give a more precise URL if you can, to be sure to execute the script on the page you want
    • the script has to be executed on each web pages causing issue
    • When calling this instruction, make sure that the page is opened, and fully loaded (see SmartBear Documentation on Wait for web pages)


    I hope it could help some of you



8 Replies

  • tristaanogre's avatar
    Esteemed Contributor

    So, as I understand it, you get this window first window with the "Permission denied" message... you then try to click on another window that is overlapped by that first and get the second error.


    This is expected.  Think about it. TestComplete is attempting to perform the same actions that a human is performing.  So, if an object to be clicked on is behind some other modal window or component, you can't click on it.  That's what the second message is informing you.

    So, what you need to do is figure out why you're getting the first error.  Does that error message come up if you manually go through the actions without TestComplete running?  If so, then the problem is not in TestComplete but in your Web Application and you will need to resolve that.

    • Felixg's avatar
      Occasional Contributor

      Hi tristaanogre,

      No, when the instruction with the "click" method call is performed, then the overlapped window appears.

      The error message does not come up when repeating these actions manually.


      As I said, the issue comes up only with Firefox (so it is not an application issue), but I have just found out something interesting : the issue comes up with Quantum ESR version of Firefox. I tried with Firefox Quantum ESR 60.1.0 and 60.2.0 : issue comes up. Trying with Firefox ESR 52.9.0 : issue does not come up.


      So, I temporaly downgrade my Firefox version, but it is not a viable solution.

      I think there is something changing in Firefox Quantum, that causes this issue when TestComplete try to interact with the elements composing the web page, but I can not go forward



      • tristaanogre's avatar
        Esteemed Contributor

        PErhaps you answered this already, but when dealing with Firefox, you need to be sure you have the proper patches applied.  There have been recent patches released by SmartBear for the latest versions of Firefox. 


        Have you verified that you have these applied?


        If so... at this point, this sounds like something to raise as a question to the SmartBear customer service team.  What it sounds like, though, is you have the FireFox patch applied for ESR 52.9 but perhaps not the latest patch so I'd start checking there.

    • Felixg's avatar
      Occasional Contributor

      Hi Marsha_R,

      Yes I applied the entire recommanded setup, and after reading your message, I spent time to check this setup one more time and it's all compliant