Forum Discussion

frogen_hyourinm's avatar
Occasional Contributor
11 years ago

Problem Running Test using TestComplete


I am using TestComplete trial version hoping to opt for the company. 

When i create my first test 'Project Suit-> Keyword Test-> Test1'. It worked very fast and correctly verifying object checkpoint. 

These were the steps: 

Then goes my second test2, it opens the browser but doesnot type in URL or select URL. The process gets too slow and wrong. Even when i create a completely new project. It works well only when i delete all projects and start a new one. 


Has it something to do with 'Object checkpoint' or something else?

8 Replies

  • tristaanogre's avatar
    Esteemed Contributor
    What is your Test2?  What are the steps being executed there?  This isn't expected behavior for TC.  If something worked with Test 1 it should work with Test 2.
  • frogen_hyourinm's avatar
    Occasional Contributor
    The test2 was 

    -open browser


    -checkpoint (logout button)


    -click yes

    -close browser

    -stop recording

    When i run test for this, it would never type in url even. I'm using internet explorer version 11. 
  • tristaanogre's avatar
    Esteemed Contributor
    I don't think it has anything to do with the checkpoint, no... 

    Perhaps, what's happening, is that there's something different about your actual page in the second test.  Namemapping Criteria for the page itself may need to be adjusted so as to account for differences.  That's my best guess at the moment.  

    Can you post a screenshot of pageRedowLoginPage in the NameMapping panel to be able to see the criteria?
    • mgroen2's avatar
      Super Contributor

      did you close the browser prior to test execution? You have to close all browser windows because all browser windows have different process number. It should match the recorded process id.

      • hsdhillon's avatar
        Occasional Contributor

        Thanks for your response mgroen2,

        Yes, I have tried to close the browsers. After restarting the TC, it works fine for once. During the recording it brakes and after that when I am trying to run my recorded test, it takes lots of time to process one step (such as: Entering a text in the username field, it enters one by one character slowly)