Forum Discussion

rstelly's avatar
rstelly
Occasional Contributor
2 years ago
Solved

Login popup not mapped or detected

Using version 49.6.7 of Testcomplete

 

Login popup from chrome is not mapped and cannot be detected by the page mapping tool when I try to add a new object.

 

If I pass the login manually and then go to leave the page, the "Are you sure you want to leave" popup is detected and mapped as expected.

  • rstelly's avatar
    rstelly
    2 years ago

    Rolling back to 15.46.9.7 resolved this problem

7 Replies

    • rstelly's avatar
      rstelly
      Occasional Contributor

      Sorry, version is 15.49.6.7

       

      Read through that page several times.

    • rstelly's avatar
      rstelly
      Occasional Contributor

      I am not able to share a screenshot but here is a diagram summarizing the issue

  • rraghvani's avatar
    rraghvani
    Champion Level 3

    Here's sample code to click on the TestComplete Dialogs Sample

    function DlgTest()
    {
        Browsers.Item(btChrome).Run("http://secure.smartbearsoftware.com/samples/testcomplete15/dialogs/");
        var page = Sys.Browser("chrome").Page("http://secure.smartbearsoftware.com/*");
    
        // Prompt sample
        var btn2 = page.Panel("page").Panel("dialogBox").Link(1);
        btn2.Click();
        Log.Message(page.Prompt().Message);
        aqObject.CheckProperty(page.Prompt(), "Message", cmpEqual, "Please enter your name");
        page.Prompt.TextBox("Value").SetText("SmartBear");
        Sys.HighlightObject(page.Prompt().Button("Cancel"));
        page.Prompt().Button("OK").Click()
    }
    • rstelly's avatar
      rstelly
      Occasional Contributor

      Rolling back to 15.46.9.7 resolved this problem

  • rraghvani's avatar
    rraghvani
    Champion Level 3

    It might be worth getting the latest version, as there's been a number of fixes, including browser dialog.