Forum Discussion

DainiusA's avatar
3 years ago

Jenkins problem with Desktop application



I have an issue with Jenkins and Slave machines.

The main problem appears then I run my full test project(tried to run .pjs and .mds files) which takes ~18 minutes to finish . The test on the computer finishes closes TestExecute(but doesn't prompt Test results on the screen), but on Jenkins it is stuck and you need to cancel it. So it automatically fails. The most interesting part that it has done the log files.



I have tried to run a small number of tests, it does finish on the computer(still doesn't prompt Test results on the Slave machine) and it has exported logs to Jenkins.


5 Replies

  • Hi DainiusA 


    In your Jenkins job, TestComplete build step, click on Advanced and in the Command Line parameters add /exit. This should force the app to close. 


    Hope this helps


    • DainiusA's avatar

      Hello mikef ,


      Unfortunately it didn't help. I have even .mht file generated on the Slave machine


      , but on Jekins it is stuck in the console at this point:


      [TestComplete] The test execution started (Maxima_WinPos_LT). [TestComplete] Found TestComplete/TestExecute installations: Type: TC, Version: 14.0.317.7, Path: "C:\Program Files (x86)\SmartBear\TestComplete 14\x64\bin\TestComplete.exe" Type: TE, Version: 14.0.317.11, Path: "C:\Program Files (x86)\SmartBear\TestExecute 14\x64\bin\TestExecute.exe" [TestComplete] Selected TestComplete/TestExecute installation: Type: TE, Version: 14.0.317.11, Path: "C:\Program Files (x86)\SmartBear\TestExecute 14\x64\bin\TestExecute.exe" [TestComplete] [WARNING] The node is connected via Java Web Start (JNLP). In this mode, the "Run interactive user session" property of the TestComplete Test step is ignored. TestComplete (or TestExecute) will work in the current user session. [TestComplete] Launching the test runner. $ "C:\Program Files (x86)\SmartBear\TestExecute 14\x64\bin\TestExecute.exe" D:\AutoTesting\Maxima_WinPos_LT\Maxima_WinPos_LT.pjs /run /SilentMode /ForceConversion /ns /exit /ExportLog:D:\Jenkins\workspace\WinPos_Maxima\WinPos_Maxima_LT\1652357752415.tclogx /ExportLog:D:\Jenkins\workspace\WinPos_Maxima\WinPos_Maxima_LT\1652357752415.htmlx /ErrorLog:D:\Jenkins\workspace\WinPos_Maxima\WinPos_Maxima_LT\1652357752415.txt /ExportLog:D:\Jenkins\workspace\WinPos_Maxima\WinPos_Maxima_LT\1652357752415.mht /DoNotShowLog /exit /JenkinsTCPluginVersion:2.8.1


  • So after more research I have found that the problem occurs only  then I run the project suite on TestExecute program and it's ok on TestComplete. Any ideas why this could be happening ? This is a bad solution for us, because our company has several TestExecute licenses and only 1 TestComplete and we need to run several projects at the same time.

  • It sounds like TestExecute does what is required, but the Jenkins job itself is somehow stuck waiting for something.  Can you post a screenshot of the build step config? Or you can DM me directly with it.




  • Any other ideas ? I have tried to swap/turn on/ turn off checkboxes in the job, but the result still remains the same with TestExecute, it doesn't matter which version is used. Everything works fine with TestComplete though.