Forum Discussion

ecsmmek's avatar
Occasional Contributor
6 years ago

Problem generating project report via testrunner in Jenkins

I'm trying to generate a project report via testrunner in a shell script in Jenkins but somehow it doesn't seem to create the actual report in the target folder.
It is a "normal" soapUI project, i.e not a composite project that is run.
The odd part is that it does generate both "Data Export" and "JUnit-Style HTML Report" reports.
This is the row generating the different types of reports. The two first examples below are working
bin/ -R"JUnit-Style HTML Report" -f$SOAPUI_HOME/logs_$USER/$test \
bin/ -R"Data Export" -FMXL -f$SOAPUI_HOME/logs_$USER/$test \
However, the below example trying to generate a project report does not create any report
bin/ -R"Project Report" -FXML -f$SOAPUI_HOME/logs_$USER/$test \
The path to the report folder is the same. It's only the type of report that differs.
Tried a few different approaches with different arguments (flags) without any luck. 
Tried to shift the " characters, e.g. "-RProject Report" in order to mimic the "original" testrunner command line generated i ReadyAPI.
Tried to add .xml to the target folder, i.e. -f$SOAPUI_HOME/logs_$USER/$test.xml but that didn't work either
Any ideas?
I'm using ReadyAPI 2.6.0 locally and version 2.5.0 is installed on the Jenkins server.
Best regards
  • Hi Community


    The problem was indeed the unix server lacking the font "package".

    After installing the fonts required the Project Reports ( both XML and PDF) were generated accordingly.


    Best Regards


13 Replies

    • groovyguy's avatar
      Champion Level 1

      I haven't attempted a project level report yet, but I can give that a shot today. I've been working with Jenkins and reports so I'll see what I can figure out and will report back. :) 

  • nmrao's avatar
    Champion Level 3



    Couple of things:


    1. Is this problem happening for the first time?

    2. Is this specific to this project?

    3. Were you able to get the required report out side the jenkins? i.e., pure commandline execution.


    Just to isolate the nature of the issue.

    • ecsmmek's avatar
      Occasional Contributor



      Hi, see answers below.


      1) We have previously been able to generate JUnit reports with a similar command (as described above) on Jenkins

      2) Not isolated to this particular project. We have several projects executing via testrunner and none of them generate project reports

      3) I've managed to generate the desired report locally on my windows machine running testrunner


      Today we're upgrading from ReadyAPI 2.5.0 to ReadyAPI 2.6.0 on the Jenkins server. I'll run some additional tests after this is done.

      • nmrao's avatar
        Champion Level 3

        If the reports are generated from command line testrunner, then there is no reason jenkins can't generate the report provided the same command is run from the build step.