Forum Discussion

rocky1's avatar
rocky1
New Member
8 years ago

Java web start application-jp2launcher.exe not displaying

Hey,

 

Im newbie to Test Complete.

 

I have a java web start application which is hosted on some server .

i launch it using cmd or creating shortcut in desktop giving command javaws.exe https://<path> or details of server to launch the application.

 

Im not able to add this in tested apps and launch it from there.Also ,application process is not getting displayed in Object mapping whenever i do object spy .It manages to retrieve object properties and identify it but it doesnt get added to object mapping and there is no process shown for the application.

 

Appliation has some v2launcher.exe process shown in task manager.

 

How can i get it to add in test complete and try to script it.

 

Regards,

Amar

9 Replies

    • EVarnavsky's avatar
      EVarnavsky
      SmartBear Alumni (Retired)

      It is definitely an issue. Ask support team to help you

  • dczerniawski's avatar
    dczerniawski
    Occasional Contributor

    I think I have the same problem. TestComplete is not detecting the jp2launcher.exe process. It maps the login window of my app to the browser:

     

    NameMapping.Sys.browser.dialog0 (see attached)

     

    But when I find the object by pointing to it with TestComplete it says:

     

    NameMapping.Sys.Process("jp2launcher").SwingObject("UIDialog$BasicDialog", "Employee Login", -1, 1)

     

    When I rerun "Login" test it fails for object not found. Maybe I can manually edit this, but the real problem is that it isn't a child object of the correct process (jp2launcher).

     

     

    • dczerniawski's avatar
      dczerniawski
      Occasional Contributor

      My problem was solved when I used an older version of Java.

      JRE 1.8.0_71 x86 -> TC did not list jp2launcher process in object browser

      JRE 1.6.0_23, x64 -> TC did list javaw process and had nested client objects

       

      jp2launcher replaces javaw in newer versions of Java and maybe TC has an issue with it. My app normally runs on an older version of Java so it wasn't a problem for me. 

      • AlexKaras's avatar
        AlexKaras
        Champion Level 3

        Hi,

         

        > My problem was solved when I used an older version of Java.

        Thank you for the update.

        (It also might be related to the https://community.smartbear.com/t5/Desktop-Testing/Can-I-test-a-JNLP-app-that-does-not-run-in-a-browser/m-p/122060#M6609 thread)

        However, this sounds strange because I definitely was able to work with the JNLP application started using both javaw and jp2launcher processes (though do not remember their exact versions)...

        As a quick idea - In TestComplete Object Browser try to use toolbar buttons (on the left of the Object Browser's toolbar) to display not only the tested applications but also all user processes and, maybe, system processes as well. Does this make jp2 launcher process visible and a parent of your jnlp application ?