Forum Discussion

ddima's avatar
ddima
Occasional Contributor
8 months ago

Click doesn't work on Chrome popup

Hi all,

after Chrome update to 116 version faced with issue when TestComplete click doesn't work on Chrome popup.

 

1. Popup is called in my web application

2. It is necessary to click on the "Open *****" button using Click() action

Result: Button doesn't click.

 

I've tried to set focus or hover mouse on the button and then perform click. Also tried to do ClickM. Click doesn't work. But set focus and hover mouse work successfully.

Also I tried to get Enabled property for this button and if True then perform Click. Doesn't help.

 

There are to ways to workaround:

1. doing press Enter key on the button

2. trying do the second click on the button if the first click was failed.

 

But it's all about risk of missing bug in future.

 

Maybe someone has idea what can I do before clicking on the 'Open ****' button?

 

ā€ƒ

27 Replies

  • rraghvani's avatar
    rraghvani
    Champion Level 3

    Are you using keyword test or script? If using script, can you share your code that performs the click?

     

    Are not able to interact with those controls shown in w3schools.com?

  • rraghvani's avatar
    rraghvani
    Champion Level 3

    In Chrome Version 116.0.5845.141 (Official Build) (64-bit) the dialog,

    Code,

    Sys.Browser("chrome").Page("*").Confirm.Button("OK").Click();

     

     

  • jkrolczy's avatar
    jkrolczy
    Regular Contributor

    TestComplete1555SLM.exe released with fix correction.

    I am verifying that now.

  • edited after testing: ive reverted back again to much earlier version of chrome to resolve my issue, below is summary from my other discussion:

     

    to summarise (all below using chrome 106, have now also tested 114 which is fine inc click OK)

     

    TC15.53 - recognises the alert/confirm fine including the text within it under a Message property and the OK button

    TC15.54/55 - recognises the alert/confirm fine, but only recognises part of the text in it under a NEW child object with ObjectIdentifier "Message" and ObjectType "Label"

     

    seems like an issue with changes in TC .54 to me...

  • warrenw39's avatar
    warrenw39
    Occasional Contributor

    I have experienced this issue off and on as new versions of MS Edge are released and TC can't keep up. After multiple reports of this issue a SmartBear Tech assisted me with hard coding the XY coordinates for the Click() event on the pop-up. It is purely a work-around, but has been working for me since MS Edge v106. It's a bit like throwing a dart at a dart board, and it can take a while to get right.