Forum Discussion

kalpana_seagate's avatar
kalpana_seagate
Occasional Contributor
9 years ago

After LDAP upgrade, command line ccollab login <url> <user> <password> doesn't work

After LDAP configuration and version upgrade, command line doesn't work.

 

ccollab login http://codecollaborator 524975 jsdsjdjs

 

throws an error,

ERROR: Connectivity problem with Collaborator server:
Unexpected Error: com.smartbear.jsonrpc.impl.JsonRequestException: Errors found:

[ {
"result" : { }
}, {
"errors" : [ {
"code" : "InvalidAuthentication",
"message" : "Your ticket is invalid. Please try to login and then reattempt this command."
} ]
} ]
You may need to run 'ccollab login' to verify your configuration settings

 

But when the command is run without passing user name and password, it prompts for the information and the same user, password works fine.

 

C:\>ccollab login http://codecollaborator
Please enter your username:
(default: 524975)
> 524975
Please enter your password:
(Input will not echo.)


Trying to login with new configuration
Connecting to Collaborator Server http://codecollaborator
Connected as: Kalpana Manoharan (524975)

New configuration worked - saving configuration settings
Configuration key 'url' saved.
Configuration key 'user' saved.
Configuration key 'server-proxy-host' cleared.
Configuration key 'server-proxy-port' cleared..

 

The password does not have any special characters (only alphabets and numbers). I tried with  single quote, double quote, but nothing works. I need this because we have some inhouse scripts which will invoke collab commands.

Any help appreciated. thanks.

 

6 Replies

  • Hi

     

    Can you confirm that both the collab client and server are the same versions?

     

    Also are you able to login to the UI with the same user name and password?

     

    Regards

    Damien

     

    Technical Sales Engineer

    • kalpana_seagate's avatar
      kalpana_seagate
      Occasional Contributor

      yes both my client and server are on same version. Attached screenshot for verification.

       

      The same user id and password works from client GUI.

       

      • OlegB's avatar
        OlegB
        SmartBear Alumni (Retired)

        Hello kalpana_seagate,

         

        Unfortunately, you have faced one of the known issues. Collaborator throws the API login ticket invalid exception before the stored one could be refreshed. The fix for this issue is included in the Collaborator v.10.0.1000 release. Please wait for the release announcement and check how it works.