Forum Discussion

Manuela's avatar
3 years ago

Hiptest-publisher error No tests imported


I'm facing this problem while trying to push the results of the tests to cucumber studio. I'm using cucumber-java. The tests run and pass, but after the command : 

hiptest-publisher --config-file hiptest-publisher.conf  --push target/surefire-reports/TEST-RunTests.xml --test-run-id 604247 --push-format junit this error is shown




[v] No tests imported 
Possible causes for the lack of imported tests: 
* Did you run the following command before executing your tests? 
hiptest-publisher --config=hiptest-publisher.conf --test-run-id=345241 --without=actionwords 
* Did you specify the correct push format? 
Use push_format=<format> in your config file or option --push-format=<format> in the command line 
Available formats are: cucumber-json, junit, nunit, robot, tap 




This is my hiptest-publisher.conf :

not_recursive = false
split_scenarios = false
with_folders = true
keep_filenames = false
keep_foldernames = false
empty_folders = false
leafless_export = false
no_parent_folder_tags = false
with_dataset_names = false
language = cucumber
output_directory = './features'
framework = java
site =
step_definitions_output_directory = './features/step_definitions'
actionwords_output_directory = './features/step_definitions'
overriden_templates = './templates'

I tried the steps from

and but the same error shows.



No RepliesBe the first to reply