Forum Discussion

jan_hron's avatar
New Contributor
12 years ago

Unsupported SCM System or Client

I'm having the same problem as some other people had a couple years ago:

Unfortunately, these posts were not helpful in solving the issue and since I do not practice the arcane magic of thread necromancy, I'm starting a new one.

The problem is that any file I add to the review are treated as if I were the author and thus there are no diffs. I use pretty much the same setup as my colleagues, at the very least the same version of Collaborator and the same Perforce SCM support plugin.

Now, maybe I'm missing something trivial, maybe I need to install the GUI client as well? Since I have no idea how the Collaborator connects with the overall infrastructure, this could also be a problem with some of its other components. Anyway, I have attached a screenshot of the error message as well as the debug log.

I really need to get this to work, so any piece of information that could lead to a solution will be greatly appreciated.

3 Replies

  • jan_hron's avatar
    New Contributor
    After downgrading to Collaborator v6, I can at least select a whole changelist in the Perforce perspective, but the problem itself persists.

    Here is some additional info:

    The issue seems to be with the Perforce integration, not Eclipse itself. When I gave up with the Eclipse plugin, I installed the GUI application. When I tried to add the SCM configuration, autodetection didn't work. This may not actually be available for Perforce, but after clicking the Validate button, the client identified one of our Perforce servers. I have no idea where it found the information, but it was our main server, whereas I wanted to use our local mirror. Anyway, whether or not I filled in the fields by hand, the result configuration was the same, containing the main Perforce server. After proceeding, I tried to add a pending changelist to a review. Then, the client complained that there are no pending changelists. Even when I filled the P4PASSWD field with the wrong password, the client behaved exactly the same!

    I would be happy if someone could get in touch with me since I'm not the only one with this problem in our company, and I'm willing to help with tracking down the problem.
  • Anonymous's avatar
    Hi Jan,

    To help us isolate the problem better, please capture the debug log, including the validation information, from within the GUI client.


    On the GUI client menu, select 'Help' then 'Capture Debugging Log'. This should bring up a Debug Log window. With this window still open, please:


    a) Select the SCM configuration, click edit, click validate, click cancel.


    b) Reproduce the issue. Once the error appears, click 'Save Log' and send us the log.  This will help us figure out what's going on.

    Also, if you could include a screen shot of your SCM configuration screen and also clarify what you mean by the term "local mirror" in your previous post, that would be great.

    I've created support case 71725 for this specific issue so please send these files to and include "case 71725" in the subject so it automatically gets tied to that case thread. Thanks!

  • jan_hron's avatar
    New Contributor
    Thank you very much, I have sent the requested information to the support.