Forum Discussion

dkarr_1's avatar
Occasional Contributor
13 years ago

Eclipse plugin can't connect to eval server

We just installed an eval of CC.  I logged in to the server from the web gui and created an initial empty review.

I then installed the Eclipse plugin into my Eclipse 3.6.2 workspace. There are a couple of confusing issues with that. First, I don't see a clear statement anywhere of what exactly the server URL should be.  On the web gui, I'm at "http://<hostname>:8070/go?...".  In the "Server Connection" section of the CC preferences in the plugin, I entered "http://<hostname>:8070".  The only other text field is "Username". I entered my CC principal there. There is no password field here. I clicked on "Test Connection" and it failed, saying "http://<hostname>:8070/xmlrpc/secure" does not appear to be running CC.  I tried that URL in the browser, and it gave me back an XML document, just saying it couldn't parse the xmlrpc request.  In other words, it appears to be fine, from that point of view.  Note that I added the plugin through the update manager, so my network connections are obviously basically working.

In my "Network Connections" preferences, I added the hostname that's running CC to the "proxy bypass" list and tried again, but I only got a slightly different error.  Instead of saying "does not appear to be running", it said "Bad protocol".