Ask a Question

Unable to find the text object that corresponds to the selected mapping item


Unable to find the text object that corresponds to the selected mapping item

I am working on CEF based desktop application and trying to automate it. The application contains multiple windows and i am able to access only one window while i am only able to maximize the other window but not able to access the objects of the other opened window.

Steps i am following : 
1. From the Name Mapping -> Clicked on Add Object

2. From the Map Object -> Drag the target to point to the object : Hereafter dragging the pointer to the desired object, its aliases has been suggested in the pop up like this 


From above image, i am able to highlight the selected object.

3. Now clicking on Ok from above window, an object is added to the Name Mapping 

4. Select the added object and click on highlight


Issue - 
After step 4, i am not able to access the object, it is not getting highlighted in the Object Browser. It is giving error as - 



Any suggestions for this???
Note : I am able to access the elements of the main window but not able to interact with the elements of the other opened window. I'm only able to maximize

Community Hero

Have you been through all of these preparation steps?

[Community Hero]
[Community Heroes] are not employed by SmartBear Software but
are just volunteers who have some experience with the tools by SmartBear Software
and a desire to help others. Posts made by [Community Heroes]
may differ from the official policies of SmartBear Software and should be treated
as the own private opinion of their authors and under no circumstances as an
official answer from SmartBear Software.
The [Community Hero] signature is used with permission by SmartBear Software.

Yes i've followed the same steps.

Additionally i've provided the command line parameters as "--remote-debugging-port=8081"

Run Mode as "Simple"

In the Object Browser, i am able to track the object but when the object is added in Name Mapping it stopped working and giving error as "Unable to find the test object that corresponds to the selected mapping item. The Object or one of its parent objects does not exist or their mapping settings do not allow TestComplete to find them in system the system".

Any suggestions or help would be appreciated
I've got stuck at a point and unable to proceed further.

Can the parent of that object still be found?

Have you tried changing the selector in the mapping?


When i tried to map the object and drag the target to point to the object till there i am able to highlight the object. Once it is added in the Name Mapping it stopped working.

I am able to map the objects of the main window of the application but i am unable to map and track the objects for other windows of my desktop application.

SmartBear Alumni (Retired)

Thanks for the replies, Community! 

@Mohit_Dadhich If none of the suggestions helped, I would recommend opening a support ticket with the TestComplete Customer Care team.

Sonya Mihaljova
Community and Education Specialist

Showing results for 
Search instead for 
Did you mean: