Ask a Question

Unable to find the object that matches the [object] item. when running an application in RunAs mode


Unable to find the object that matches the [object] item. when running an application in RunAs mode



When I run an application in normal 'Run' mode the application I'm running works consistently; however, when I run the application in 'RunAs' mode (I need to test authorisation functionality so need to run the application under a different user account) it doesn't recognise objects previously mapped and recorded in the NameMapping section. I've confirmed this using the object spy and analysing the name mapping


I'm at a loss as to how to fix this. I've tried all the suggestions that I can find including ensuring TC is run with administrator priviledges. I even 'RanAs' the same user currently logged into the machine with no success


Does anyone have any ideas as to what might me causing this






Thanks for your information


Why do you think that it's only a problem in RunAs mode? TC never has a problem finding the object in normal Run mode

I can't tell without seeing the code

I am thinking the Delphi code is checking to see if you are logged in as admin or not and firing up the popup differently in each case.


It is easy to figure out once you see the code why it is behaving that way




I've managed to run it through TestExecute OK using command line, so it only seems to be a problem with TC


I'll speak to one of our developers to review the application's code



SmartBear Alumni (Retired)

Hi @awhawh,


Were you able to resolve the issue? Please share the solution with us.

Tanya Yatskovskaya
SmartBear Community and Education Manager



Initially it worked when running the test through TestExecute from command line. I decided to launch TestComplete.exe directly from the application bin directory. This also worked.


The problem was running TestComplete from the desktop icon that was created during the installation process

Showing results for 
Search instead for 
Did you mean: