Ask a Question

Tested App not visible until after test fails because UI does not exist


Tested App not visible until after test fails because UI does not exist

So I'm running a tested app through a subroutine in my script.  My script runs the app, but the app will not display in the UI until the script run fails because the app children "don't exist."  The app UI displays on the screen immediately after the test fails.  Has anyone encountered this before and is there a way to get it to stop doing that?  Some more info - I am running the same app from a different script without a problem.  It's so far only happening in this particular script.


I tried several things to fix it, and one thing worked.  TC was failing to enact the timeout I had set because it couldn't see the the window; I put in a delay command with the same length as the set timeout immediately after the run command.  Gave it just enough time (interference?) to let the program UI pop-up and TC continued with the test.

Community Hero

Instead of a hard coded delay you would be better off implementing on of the many wait commands. This will wait up to to a specified maximum amount of time before continuing. A hard delay could be not enough time, or actually inflate test time if the app becomes usable before the delay expires.



Click the Accept as Solution button if my answer has helped

I did not know those existed.  Thanks!

Showing results for 
Search instead for 
Did you mean: