Ask a Question

TestExecute sometime dont close even with the /exit argument

SOLVED
GGuezet
Contributor

TestExecute sometime dont close even with the /exit argument

Hi everyone, I'm currently experiencing a weird issue.

 

After an upgrade from TestExecute 12 to TestExecute 14.60, sometimes TestExecute doesn't close after completion.

As I am using Jenkins to launch a serie of ProjectSuite, if testExecute does not close, every other Project Suite are not launched as the previous one is seen as running.

 

I've attached a picture of TestExecute not closing even after completion.

Even if I'm right clicking the icon and click on "Exit", nothing happen and TestExecute stays opened. I am forced to kill the process to exit TestExecute.

It does not happen during the test execution, but only when all tests are finished...

 

The command line launched by Jenkins via the TestComplete plugin:

 

 

'"C:\Program Files (x86)\SmartBear\TestExecute 14\bin\TestCompleteService14.exe"' //LogonAndExecute //lDomain: "" //lName: "Testadmin" //lPassword: ******** //lTimeout: "14580000" //lUseActiveSession: "true" //lCommandLine: '""C:\Program Files (x86)\SmartBear\TestExecute 14\x64\bin\TestExecute.exe" "C:\Jenkins_Infra\workspace\MICRO-SESAME - Tests journaliers VBS\Projets\ACCES\ACCES.pjs" /run /SilentMode /ForceConversion /ns /exit "/ExportLog:C:\Jenkins_Infra\workspace\MICRO-SESAME - Tests journaliers VBS\1597996642359.tclogx" "/ExportLog:C:\Jenkins_Infra\workspace\MICRO-SESAME - Tests journaliers VBS\1597996642359.htmlx" "/ErrorLog:C:\Jenkins_Infra\workspace\MICRO-SESAME - Tests journaliers VBS\1597996642359.txt" /Timeout:14400 /DoNotShowLog /JenkinsTCPluginVersion:2.5.1"' //lSessionScreenWidth: "1920" //lSessionScreenHeight: "1080"

 

 

 

This command line is the same for every Project Suite launched, and hangs only sometimes. I have never encountered this issue after almost 3 years of using TestComplete/TestExecute 12...

 

If you have any solution or idea, that will be awesome.

 

Thanks

3 REPLIES 3
GGuezet
Contributor

Okay I think I've found the error.

On TestExecute logs, Silent.log, there is the following log each time TestExecute is trying to close:

 

 Tried to open the error dialog? Message; At least one modal dialog is open.
Please close all the modal dialogs before closing the project suite..

And indeed, I have a modal dialog opened (A zip compression error).

I already had this dialog in TestExecute 12 without having any issue, but it now seems that this dialog prevent TestExecute from closing...

sonya_m
SmartBear Alumni (Retired)

@GGuezet Great that you found the cause of the issue. Did you find a way to work around this?

 

The change in behavior could be caused by the new tool version. But I think the Support Team would need to look at your issue more closely to investigate this properly. 


Sonya Mihaljova
Community and Education Specialist

The solution I have found is to update my code to properly handle zip compression errors (Files used by another process, etc...)

So without a modal dialog, TestExecute is closing correctly 😉

cancel
Showing results for 
Search instead for 
Did you mean: