Ask a Question

TestComplete - Network Suite - Host Verification Failure


TestComplete - Network Suite - Host Verification Failure

Hello  - 

   As I am trying to find a solution to this issue myself I thought I would branch out and try to tap the infinite pool of knowledge the people in this community have. 

Problem is I cannot get a networked host machine to get verified successfully when I click Verify on the Host tab in my Network Suite of my Master Project . See screenshot attached for error returned. 

Supporting info, e.g., setup: the Host machine is in our network and I can connect to it via RDP with no issues. Please see image for specific details Ive setup in TC. 

Any help is appreciated. 

TC Host Failure.png

Community Hero

Please make sure ports 6090 and 6092 are open on Master and Slave in the firewalls

Also make sure TestComplete or TestExecute (whichever you chose to use) is working correctly on the slave machine before starting the distributed test


Good luck


Ive followed the setup for the firewalls - inbound and outbound rules. Ive tried those specific ports for both local and remote ports, and then All Ports for both. I get the same result. 

Thanks for your reply. Is there anything else I can check?

I will recommend 2 more things and hope it will help you

1- Try using the IP address instead of the machine name and see if that solves the problem

2- Make sure the version of TestComplete and/or TextExecute are IDENTICAL between the master and the slave.




This may or may not be the issue - does the host machine need to have TC or TE installed just to pass the 'Verify' process on the Host tab? The remote host Im trying to verify connectivity to doesnt have either installed. 

Im working with a trial license so only have one instance of TC installed. 

Esteemed Contributor

IIRC, the verification does require either TC or TE to be on the target machine.

Robert Martin
[Hall of Fame]
Please consider giving a Kudo if I write good stuff

Why automate?  I do automated testing because there's only so much a human being can do and remain healthy.  Sleep is a requirement.  So, while people sleep, automation that I create does what I've described above in order to make sure that nothing gets past the final defense of the testing group.
I love good food, good books, good friends, and good fun.

Mysterious Gremlin Master
Vegas Thrill Rider
Extensions available

Ok now I have installed TestExecute on the remote host. I can connect to this host via RDP myself. I have pinged the IP of the host successfully. I have the ports set to All Ports for everything TC and TE on both the Master and Slave machines. I am still getting this Server Not Started error. 

Im now suspecting a possible defect of sorts. There is no reason these two machines cant communicate.


Are there any other suggestions?



SmartBear Alumni (Retired)

Hi @Southpaw,


If you haven't contacted the Support Team to investigate this issue yet, I suggest that you do this and describe the current behavior. You can contact them here:

Tanya Yatskovskaya
SmartBear Community and Education Manager


Hi there,

I am using distributed testing via the NetworkSuite a lot and know the pain with it.


First you should read the Article about the Requirements for distributed Testing.
You have to follow those steps to get your client up and running propperly.

You can find it here.


It sounds like you did not configure your machine to allow unsecure RDP connections.


Than the Ports that are documented are wrong.

After Patching TC to Version 14 they changed the default Ports.

They are now TCP 6095,6096,6097

If you are not sure about the Ports you can look them up in Tools -> Options... -> Engines -> Network Suite.


I would first try to get RDP Connections running and make sure you can ping and connect to your Client from your Host.

Than You need to configure the Firewall with the mentioned Ports.




@ConstantinNeoz  Thanks much for the detailed reply. I appreciate it. Im still going through the setup. But in the meantime, regarding the TCP Ports (default as shown in Tools>Options>Engines>Network Suite for the lates version of TC, mine still show the 6090 (editable), 6091,6092 (both static). Are the new default ports your reply mentions supposed to be the ports displayed in the UI?



Showing results for 
Search instead for 
Did you mean: