Ask a Question

Object Identification

SOLVED
bryanhirst15223
New Contributor

Object Identification

I have a desktop app I'm trying to run some simple production canary tests on. I have messed around with Testcomplete a little bit in the past, and ran into this same issue as well, and found a fix, but I cannot remember what it was or where to even look to find it again.

 

Here's my problem: I try to identify some text fields and buttons, and Testcomplete can only find the entirety of the app, as a whole, as an object, no matter where I put the Object Spy. 

 

I seem to remember some checkbox in a setting somewhere that, once I checked it (months ago, in a different project), allowed Testcomplete to actually recognize objects. 

 

Anyone know where this can be found? 

(the app has ID's for everything too, so that's not the problem)

4 REPLIES 4
Marsha_R
Community Hero

There are lots of things in Project Settings, but I would wonder what kind of app/browser you are using?  Perhaps the setup isn't done on this computer.


Marsha_R
[Community Hero]
____
[Community Heroes] are not employed by SmartBear Software but
are just volunteers who have some experience with the tools by SmartBear Software
and a desire to help others. Posts made by [Community Heroes]
may differ from the official policies of SmartBear Software and should be treated
as the own private opinion of their authors and under no circumstances as an
official answer from SmartBear Software.
The [Community Hero] signature is used with permission by SmartBear Software.
https://community.smartbear.com/t5/custom/page/page-id/hall-of-fame

It's a purely desktop, installed application. I've had Testcomplete installed on this pc for almost a year but have not used it much, and my current project is brand new (well, my current test suite). So I'm sure there are plenty of things I haven't yet configured 

Okay then start here!

https://support.smartbear.com/testcomplete/docs/working-with/managing-projects/project-editor/proper...


Marsha_R
[Community Hero]
____
[Community Heroes] are not employed by SmartBear Software but
are just volunteers who have some experience with the tools by SmartBear Software
and a desire to help others. Posts made by [Community Heroes]
may differ from the official policies of SmartBear Software and should be treated
as the own private opinion of their authors and under no circumstances as an
official answer from SmartBear Software.
The [Community Hero] signature is used with permission by SmartBear Software.
https://community.smartbear.com/t5/custom/page/page-id/hall-of-fame

AHHHH.png

This ended up being the solution, for me anyways. Checking the * box in both locations marked with arrows, in case anyone in the future is curious. It'll reduce performance, but, that's what will work for me personally. Thanks!!

cancel
Showing results for 
Search instead for 
Did you mean: