Ask a Question

Never able to find object even directly after mapping it

Novari-QA
Frequent Contributor

Never able to find object even directly after mapping it

I am working with a new project and we have a modal. This modal pops up infront of the user and the user requires action within the modal.

When attempting to use the spy to locate the object, I have no problem. But immediatly after mapping the object, I right-click, highlight object and it fails.

Does anyone know what is happening here? Its consistant and its blocking me

2 REPLIES 2
tristaanogre
Community Hero

Re: Never able to find object even directly after mapping it

Can you give a screenshot of the following:

 

1) Object browser showing the modal that you're trying to map, including properties and the hierarchy of ancestor objects

2) NameMapping for the modal including the hierarchy of ancestry objects, including the properties that you're using for identification.

 

It's hard to say "This is why NameMapping is failing" if we don't have anything to go on.


Robert Martin
[Hall of Fame]
Please consider giving a Kudo if I write good stuff
----

Why automate?  I do automated testing because there's only so much a human being can do and remain healthy.  Sleep is a requirement.  So, while people sleep, automation that I create does what I've described above in order to make sure that nothing gets past the final defense of the testing group.
I love good food, good books, good friends, and good fun.

Mysterious Gremlin Master
Vegas Thrill Rider
Extensions available
Novari-QA
Frequent Contributor

Re: Never able to find object even directly after mapping it

I killed my namemapping tree structure and it seemed to have solved it. I can no longer reproduce.

cancel
Showing results for 
Search instead for 
Did you mean: