Ask a Question

Namemapping Custom attributes no longer detected by spy/existing mappings not found during test

Frequent Contributor

Namemapping Custom attributes no longer detected by spy/existing mappings not found during test

Hi everyone,


need a bit of help with an issue. I have a custom attribute added under the project properties (Current and Default) to allow it to be added as a namemapping criteria . This has worked fine until today.

Went to run test this morning and have discovered that objects previously mapped using the custom attributes are no longer detecteable during the test run and also if I use the object spy to view the object properties the custom attribute is no longer displayed.


I usually had to navigate up the object tree to a parent element to find the custom attribute but it was always detectable. I have used the inspector tool in 2 browsers (Chrome and Firefox) and the custom attribute does exist on the objects in questions i.e. there has been no change in the tested application that removed the attribute.


The only recent change to the keyword test that I made was to add a browser loop to the keyword test. I don't see how that could casue the issue, given that the custom attribute no longer appears when I use the object spy to examine the object on the web page.


Any ideas???Smiley Frustrated


Champion Level 3



I would vote for either browser or OS update.

Check if some update for the browser exists on SmartBear site (


P.S. Have you tried to reboot? 😉


  /Alex [Community Champion]
[Community Champions] are not employed by SmartBear Software but
are just volunteers who have some experience with the tools by SmartBear Software
and a desire to help others. Posts made by [Community Champions]
may differ from the official policies of SmartBear Software and should be treated
as the own private opinion of their authors and under no circumstances as an
official answer from SmartBear Software.
The [Community Champion] signature is assigned on quarterly basis and is used with permission by SmartBear Software.

HI @AlexKaras I applied the Patch and rebooted, seems to have solved the issue.


Thanks Smiley Very Happy

Showing results for 
Search instead for 
Did you mean: