Ask a Question

Name Mapping issue ("Object not found" error)

New Contributor

Name Mapping issue ("Object not found" error)

We are a team of 3 working on desktop application automation. When we try to execute one script from system A in system B "Object not found" error is thrown. Please suggest how to proceed. If we merge name mapping files and make a master copy, will that allow the script to run successfully in individual systems? 


You need to supply more detail to obtain a precise answer.  Some things to look at:

1.  For desktop applications, not all desktops are built the same and some objects may be named differently.  I find this particularly applies to WinWord processes.  You need to determine what objects are found on one desktop and not on the other and then review what properties identify those objects in name mapping.  Once you identify the name mapping aliases / identifiers.   What are the differences between the identification properties on the two machines?  Are you able to modify/regularize the object identification properties to allow for the different object identification properties on the different machines?  If not, research how to use the findchild/findchildren methods in Testcomplete.

Community Hero

Merging your name mapping could help, yes.  Be sure and keep a copy of each individual one in case you want to start over.


Once you are working from the same mapping, if you still get the object not found errors, then the easiest thing to check is to see if it's a timing issue.  You may need to put some Wait or Delay messages in to make the test work amongst many machines.  


Let us know what happens after the name mapping merge and we can go from there.

[Community Hero]
[Community Heroes] are not employed by SmartBear Software but
are just volunteers who have some experience with the tools by SmartBear Software
and a desire to help others. Posts made by [Community Heroes]
may differ from the official policies of SmartBear Software and should be treated
as the own private opinion of their authors and under no circumstances as an
official answer from SmartBear Software.
The [Community Hero] signature is used with permission by SmartBear Software.

Thanks for the reply!. Added delays to the script. But still same error. The mapped object is not found or recognized when the name mapping files are merged. Should I re-map or spy the object which is not found and add it? 

Spy the object and determine what the property differences are.  Once you determine the property differences - you will be able to make an informed decision if adding a new object to the namemapping files or modifying the current properties of an object already in the namemapping files is the correct response.

Showing results for 
Search instead for 
Did you mean: